Failed to initialize plugin


I’ve got a problem concerning initializing a plugin called “STS-21” by H.G. Fortune while creating a song.
Everytime I try, it seems that Renoise even don’t try to load it. Instead, the message “Failed to initialize plugin” pops up immediately.
After rescanning the VST’s the problem’s still there: Initializing failed.

If I try initializing the plugin while working on another tune, it initializes without any problems.
I checked if I’m probably out of memory, but obviously this is not the problem.
Or is there a limitation for the quantity of plugins being used in a song I don’t know about? I guess not.

My system is: Windows XP 32bit (3GB memory).
My Renoise version is: 2.7.1

Does anyone out there have an idea what might cause the problem or what I can do?

Thank you!

Have you tried that?
Another thing you could try if you like to hack around in your song is copy your xrns songfile, then extracting the song.xml from the xrns (rename to zip), remove the instrument entries that do not involve that plugin, then reinsert the song.xml back into your duplicate and rename the .zip back to xrns and see if it still fails in that case.
It might perhaps also be that the parameter chunk may be corrupt, or if you updated your plugin, there may have been changes that invalidated your old saved parameters.

Ok, thanks for your answer. I think against expectations the RAM is the problem. While trying out a few things, a window including the message “out of memory” popped up. That never happened before and I also couldn’t find a memory problem while inspecting the task mananger or the system. So it seems that the problem is solved. The result is, that I apparently need to get a new operating system. I’m thinking about Windows 7 64bit and about 10 GB RAM. I guess from then on I have to get a new Renoise version, too…