[fixed] Glide command and volume control problems


(MattD) #1

I’m including a small XNRS demonstrating the problem.

I’ve only tested this on 3.1.0.

I noticed this when a glide made a note louder, but I think something else might be going on with multiple volume samples and adjusting volume.

The instrument here was generated by Renoise’s render plugin to instrument feature.


(detektiv_plok) #2

Hi, I think you have to activate the velocity mapping in the keyzones tab. Works correctly here when activated.


(MattD) #3

Thanks,detektiv_plok, I didn’t notice that it was disabled. I didn’t know that’s what_Render Plugin toInstrument_would do since I don’t usually render multiple with multiple velocities. If that’s the intended behavior, then it might not be a bug.

Some of the behavior demonstrated still seems weird. Disabling the velocity mapping seems to behave in an asymmetrical way depending on whether you began loud or quiet.


(detektiv_plok) #4

Yes, you’re right. When velocity mapping is disabled, the initial volume state of a pattern note seems to determine how subsequent volume changes are interpreted. For initial values in the volume column smaller than 80, a subsequent volume increase actually results in a decreasing volume.

This also happens when the volume is changed via the MXX pattern command, but here altering the value for a specific note also produces a click. Doesn’t happen with velocity mapping enabled. In the manual, MXX is not described as a sample note volume command by the way.