[fixed] Linux: High, growing CPU usage in Redux with Bitwig


(Tom Gaudasinski) #1

There is an issue in Redux that really annoys me, and it is that over a period of time Redux will increase the amount of CPU it consumes. I use Bitwig studio, and if this turns out not to be a Redux bug, but in fact some sort of a Bitwig bug, then I will take this up with the Bitwig devs, but it only happens on Redux, so I assume it is Redux that is the issue.

  1. Add Redux as instrument.
  2. Load some sample into Waveform (I used noise).
  3. Assign some macros to some parameters (I used volume, pan, and Digital Filter cutoff).
  4. Close the Redux GUI.
  5. Modulate the Redux macros from within Bitwig (I used some manual automation and some LFO).
  6. Add a clip in Bitwig that plays a Redux note.
  7. Loop it (in Bitwig).
  8. Play (in Bitwig).

Redux will start off fine, playing nicely, but go and have a cup of coffee. Seriously, it may take up to 20 minutes, but over that time the amount of CPU Redux consumes will sloooooowly creep up, until finally Redux will be using 100% of a core and will click, pop and distort like no tomorrow. However! Here’s the kicker: Once you’ve got it to click and pop like no tomorrow, the CPU will immediately return to normal (low, maybe 5%) as soon as you open the Redux GUI. Go ahead, press the GUI button when you get it to click and pop.

I’ve uploaded my project file that contains the automated Redux instance. It’s all done for you, just open the project and hit play. It’ll loop away, and all you have to do is wait.

https://filebin.net/pi48su87b23h7i7s


(Tom Gaudasinski) #2

Any movement on this? When is there a patch release for Redux planned?


(taktik) #3

Haven’t had a chance to look at this yet, but will.

Which OS are you running Bitwig and Redux on?

Had anyone else here similar problems? Can someone else replicate it with the song provided by tom?


(Tom Gaudasinski) #4

I’m running Bitwig 2.4.3 on Linux.


(lilith) #5

Does it also happen with e.g Reaper or Ardour? Do you have Debian or Ubuntu?


#6

I think you’ll find you can also just use Renoise as a host (Linux 64, Renoise 3.1.1, Redux Demo 1.0.1) enable ‘run as sandbox’ to see the audio plugin server as a separate process. In Renoise, (using instr Automation and a LFO to wobble a macro, no Redux gui shown), looks to me like a memory leak, coupled with a slow rising CPU utilization :slight_smile:


(taktik) #8

Digged a bit deeper here. It’s a Linux and host specific problem. We do rely on Linux to be called from the host in the main thread every now and then to clear some memory and stuff.

There are VST idle functions for this, but it’s a mess. No one knows how they really “should” work. I’ll reach out to the Bitwig devs to sort this out or try to work on a workaround.


(Tom Gaudasinski) #9

I think you’ll find you can also just use Renoise …

Thank you for confirming, 4tey

Digged a bit deeper here…

Awesome. I’m glad to hear that it has been confirmed. Look forward to hearing what you’ve figured out, taktik.