G# Bug Windown 7?

Hi peeps, I’m using renoise 2.5.1 (win 7 64-bit)and after working with renoise literally after 5 mins everysinglegodamtime, renoise goes crazy and jams holding down g# note, this happens every single time i use renoise? anyone encountered this? It’s defo renoise as I can start any other apps and my keys aren’t sticking, I have also tried this with external qwerty keyboards with the same effect… really nutty bug anyone have any ideas what it could be at all?
danke in advance ++

Thats fucking crazy, man. The only thing I can think to say is that its not windows7’s fault. I’m pretty sure I played a g# last night. <— win7 64bit

Sounds like a midi feedback issue (but still quite an odd one)

Have you installed Midi Yoke or anything like that?

Could indeed be a feedback issue, though you should also get an error from the driver in case of MidiYoke.
Might other programs simply ignore feedback messages.

This is happening to me too, and I use OSX Snow Leopard (64-bit). Once, it happened to me while I was live recording, and I saw the problem. The note off was, for some reason, being triggered before the note. :huh: This can happen with all keys, not just G#.

Thankfully, it doesn’t happen often. :unsure:

Hmmmmmm. I use mac OSX Snow Leopard 64-bit.
Is the 64-bit environment causing Renoise problems? I’m great at renoise, but not at programming. :blink:

[center]I use Windows 7 64 Bit Professional and have yet to experience this problem but I will take heed and definitly look out for it… Thanks guys! When this happness to someone can you guys maby post what actully went on behind the scenes so to speak, I’d love to take a look at it.


Hey peeps,
I don’t think it’s a midi feedback issue as I do not have anything connected to my pc except a qwerty keyboard. I’m not using midiyoke, all I’m using is renosie 2.5.1.
I downloaded 2.5 and the bug has occured in that once also… but it’s defo not as frequent as in 2.5.1. The bug btw doesn’t occur when I play a g#, i can play a g# no probs, it’s just after about 5 mins if I am in edit mode the bug starts itself and it keeps writing in g#. (it’s like a loop starts or something…) It’s getting annoying as Its so unpredictable. thanks for the responses everyone btw! loving the new update ++ couldn’t be happier with where renoise is going!!

Might be a Direct-Input incompatability perhaps then. Counted that the caps-lock at some desktop also needs to be hit twice before Renoise notices it.
I think the other programs, don’t use DirectX for communicating with keyboards and mice while Renoise does.

Except for this post. Or has Mac started using DirectX?

Or do you not think that is actually the same problem?

Mac not, but i was responding to the initial poster who has Win 7.

I couldn’t extract the fact it regards an ordinary PC keyboard in your case.
The first hunch usually is a faulty keyboard controller (on the mainboard)
I’ve never experienced this issue in any Renoise version.
But currently i’m still using Windows XP 32 bit.

I have the same issue. Also on Win7 64, and always with G#. It doesn’t happen very often to me (I’m using 2.5.0), and it seems to occur at completely random times. I always thought it was a problem with my laptop keyboard (I have an Asus UL30A). I’m also having the Caps Lock issue, so maybe they are indeed related.

I’m pretty sure it is a different problem, the windows issue seems to be specific to G#.

So, how do we find out if it’s indeed a faulty keyboard controller? The directX diagnostics utility isn’t very helpful.

Fair enough, hence the second question in my post. Just making sure the post by Insanity hadn’t been missed as it could maybe be related.

I just found out something: I can sometimes (not always, but most of the time) reproduce this by pressing the Fn key on my laptop keyboard and one of the arrow keys.

This key combination should normally control Windows Media Center, but I disabled this because every time I accidentally pressed this key combination, Media Center would be launched (which happened quite a lot since the Fn key is located conveniently between the Ctrl and Alt keys).

So it seems that, at least in my case, this problem is caused by me pressing the wrong key combination, in combination with some strange behavior from my laptop keyboard.

ok, 2 things

  1. I’m using a new Asus laptop, don’t know the model no. but is spanking new.
  2. I also having the caplock issue where I have to press it twice for note off.
    tried pressing the function button nothing happens when I do, it seems that this bug is just generated randomly after about 5/10 minutes use of renoise.
    Any one any other ideas what I can do? appart from buy a new machine? I’m really stuck here as I can only work for ten mins before things start going nuts again…