Genrate Drum Kit Issue

Hey folks, encountering a strange problem when creating a new kit by dragging a load of samples into a new blank sampler, after I hit genrate drum kit renoise genrates the kit but it is turning on looping automatically, is there a way of getting it to genrate the kit with loop off?
thanks! :unsure:

Looping? What for looping?
Are you sure this is done after the generate drumkit hit or does Renoise interprets a sample wrongly?

This might be a bug, in that case i could advise you to create an xrni of the sample-pack (without the key assignment so that this can be reproduced out of the box) and send it to taktik (paste an add-sign and renoise dot com behind it).

well all I’m doing is dragging a bunch of samples into a new blank instrument then hitting generate drumkit,
then all of the samples are looping with the start and end point of the loops set at the start of each sample.
so each sample sounds like a granular buzz…

I just think that Renoise interprets some sample header information wrongly, at least this is much more likely than that Renoise would start setting loop related stuff to samples after hitting the drumkit button. This button only calls a routine that binds sample-slots to note-keys.
If you would load the sample you may probably notice the looppoints even if you haven’t touched the drumkit button yet.

BTW has anyone else hadd this issue?

i’m not sure but try this:

right klick on a sample in samplebrowser, choose “load sample with options”, check “ignore loops” and “use as default”…

perhaps that helps

thanks! will try it out ^_^

Tried out your suggestion weedwalker, didn’t work, must be a bug it seems… :(
will see if taktik

Hey Vv I don’t know what you mean by “paste an add-sign and renoise dot com behind it”, I’ve made up the
xrni the way you suggested, but do you have a contact e-mail for Taktik, I tried using the memebers email links but it doesn’t allow me to email him :unsure:

Just type in taktik and add behind his name. i don’t type it in full here because of the spam-crawlers that can pick it up easily.
You can also add the samples in a zip-file (not imported and then saved as xrni) so that taktik can inspect the wave-files from its source.

Please check if you have really ignored the loops, by opening Renoises prefs -> Im/Export -> Wav Import -> Ignore Loops

The samples you are trying to import simply seem to have a (bogus?) loop set. To be sure, could you send me such a sample by mail?

I don’t think I’ve ever seen a .wav that’s ever had an actual preset loop in it. Every “loop” I’ve seen has been completely accidental. That being said, is this feature turned on or off by default?

that was ther issue! tahnk you for vour help very much appreciated you foklks rock!!
thanks again!! :)