Help with key-repeat

Hello guys,

I’ve installed beta version of renoise but all of a sudden when i hold my (for example Z (c3)) notes don’t repeat like it used to. For example i set step lenght to 1, enable record, put my cursor on first note, and then press & hold Z (c3) my cursor doesn’t move downward (like it would with step length 1).

my goal is to hold one note which would just enter same note and keep scrolling, but in this case, it doesn’t happen when i hold button, i have to constantly press it…

for example when i hold arrow down, it just goes to one field down and stops, same for all directions… :confused:

Now i’ve reverted to 3.2 version, and it’s the same ~ my conclusion is that this is some key-repeat function which i obviously cannot find, which i probabbly accidently pressed and cannot revert.

Can you please help?
Thanks in advance

That may a dumb question, but do you press ESC key to enter record mode before holding Z?

If so…do you have installed a new application that runs in the background and grabs the Z key? Do other keys work? Do single input (not holding the key) work?

1 Like

Go to settings and reset all key shortcuts.I do this every time in Renoise latelly because there is something weird happening with the key bindings.Also try starting Renoise in admin mode if you are in Windows 10,Microsoft gave us some bugs in the latest updates,wasapi does not work anymore for example.

1 Like

i’m on osx, so no,
@spktkpkt, as i mentioned, it’s not related to “Z”, it’s with every arrow direction as well. Single input works.
i don’t get it :confused: will try to restart shortcuts.
Before reseting shortcuts, i tried once more and guess what? now it works… This osx is crappy.
Thanks for help tho! <3

1 Like

I wonder why you prefer using Apple’s products when all they do is shit on the customers all the time.I am not saying Windows is better but I just don’t get people these days.Also Linux has come a long way in music production and it’s free.

1 Like

I found a very old post about this problem, maybe it’s still valid nowadays. Can’t test it because i don’t own a mac.

1 Like

@stoiximan, i have Linux on my machine at home, but within the company we have laptops (which is mbpro) and i use it for work and renoise as well, since i don’t want to switch environment often. I would never personally buy anything from Apple!! That doesn’t make Microsoft better neither. Linux is the thing… I don’t want to send statistics, i don’t want to pay something that you can have for free, that you can customize everything… etc…
Except my work, i personally do not involve into Apple/Microsoft NEVER!
Cheers and thanks for the reply
@spktkpkt When i had issues with key-repeat, it was only in renoise, all apps were doing key-repeat normally.
Vim (text editor), iTerm, Chrome, etc just worked fine, only renoise behaved strangely, and when i got home after work i decided to give it a try once more, and guess what? -it worked! i don’t know what was the cause, the thing is that it works now and i really don’t want to know.

Cheers guys! i will continue to renoise now :stuck_out_tongue:

1 Like