High Cpu Load In The Pattern Editor

I have an Athlon XP-M 2400+ with a crappy, integrated graphics card(shared memory).

When the pattern editor is open the CPU load jups for about 60%! :blink:
It doesn’t matter if the view “follows” the song or not. Neither does matter if I turn off that ‘Enable GUI effects’.

All other (non pattern editor) views are quite similar in CPU load.

I thought that this could be a graphics problem, because when I had the Task Manager window over Renoise, the CPU load decreased by about 7%.

I would like to know if this happens to everybody or not.

Also because I will know how to upgrade my laptop if it’s a graphics card issue.

p.s. Recently I did a comparison of CPU usage between Renoise and SX2. Well, Renoise used about 7-10% more, while NOT in the pattern editor. But it was only one project, not a serious test.

I also experience a big CPU load for the GUI… probably because I only have an old Geforce 2.

Anyway, you shouldn’t focus on what percentages are shown… the problem is Renoise’ CPU meter only shows the audio load (which is not really true, but at least it should) and the task manager often show 100%. This is because the GUI eats as much CPU as is left. All this makes it hard to do any fair tests…

What you can do is decrease the UI frame rate in the configs if you haven’t already. This will cause the UI to not be as responsive, but free up some resources.

Thanks, I’ll try the ui thing…

It’s not a big problem, the audio still works fine… but the laptop’s cpu is constantly at 100% aka the fan(noise) is on all the time.

I really wonder if upgrading a g. card would make this work normal.

Ok, I see the problem. But in fact this is normal in a way… just like a game which comsumes all CPU to show the graphics as smooth as possible.

Anyway, the frame rate setting will probably help you out. Let us know how it works out…

One thing that still surprises me a bit though is that turning off pattern follow doesn’t seem to decrease the load. That would mean redrawing only two pattern lines instead of all… (But maybe I’m wrong, it could be much more complicated than that)

by the way, the next version of ReNoise should have a faster GUI (i.e. less CPU load). It’s somehow too early to ensure this, but if you can cope with your graphics problem for now, don’t change your graphic card :)

Ok: reducing the UI framerate DID make a big difference.

I found out that Renoise has “two lives”:

  1. In the windowed mode
    When you reduce the ui framerate, the CPU load goes down significantly, but the graphics are very slow, hard to use under the value of 10.

  2. In the full-screen mode
    Reducing the ui framerate does not make ANY effect; neither on the CPU load, nor on the speed of graphics. The graphics work fast, smooth, and the cpu load is not very high.

LOWEST cpu load: Windowed mode, extremely low ui framerete value.
MEDIUM cpu load: Full-screen mode, any setting.
HIGHEST cpu load: Windowed mode, high ui framerate value.

Bottom line: It’s ok, if you use Renoise in full-screen. Less ok if you use it in windowed mode.

(Note: I did only a QUICK test, with one project/song only.)

If anyone has more suggestions and/or clarifications I would appreciate them.

i’ll try this on my machine at home tonight and let you know what my findings are. :lol:

another thing i noticed:
i just reinstalled windows. so everything is fresh.
is it normal that renoise shows me a cpu load of less than 5% and the windows task manager goes from around 30% to 40% ? and that with lets say: 5 tracks playing just plain samples?
no other program (FL studio) wastes so much cpu with nearly the same track amount and only samples being played.

other settings: echo mia soundcard. 128 samples latency with asio driver. windowed mode, 70 hz.

Just to add to this… (I guess that the devs are already aware of these things.)

The one that uses the most cpu tho, is the sample editor, when you play a sample.

And, just like in the pattern editor, this doesn’t affect audio playback, so no big deal.