How To Mute Vsti To Save Cpu Load

i use renoise in a live playing environment. using a midi controller, i will assign the midi device to multiple vsti’s and sample/instruments. each vsti or sample is then routed to it’s own track so i can program whether or not a specific tracks volume is up or down (being able to do pre-programmed switches between instruments). i have noticed that when i have the track “off”, the vsti/samples still play at the tracks specified volume. at this point i use the tracks volumes to turn instruments on/off. it works great, though renoise is still triggering all instruments. not a big problem, but when i have my midi controller routed to 8 instances of a cpu hog vsti it can get hairy. this whole scenario is only relevant when live playing through renoise.

is there a way to get vsti and instruments to stop registering in cpu when track is “off” when live playing through renoise? the same way as when programmed note data is input?

You can change the mute mode in the Plug/Misc preferences for the tracks. In one case, it simply “mutes” the tracks but still triggers the instrument, in the other case it really "off"s the track and the VST instrument is not triggered at all (depending if there aren’t any aliasses around that still are triggered).

that solution works fine once note data is input into a track. i set my tracks up w/ various efx commands only, and then play my midi drums triggering vsti’s through the track while playing live. no midi/note data is being recorded. i wonder if the way midi data flows through programs makes this out of the question? note data triggering the vsti versus midi controller triggering vsti. i think this is all a sign that i will need an xxxtra beefy rackmount desktop w/ win7 64 for my live setup.

The simply change the channel on your midi device and take care the plugin is not listening to that channel. I guess you have midi devices that keep feeding LFO and other fx CC commands to Renoise right?