Is there a way to turn off note off when using the computer keyboard?

I have sliced up a drumloop and want to use the keyboard but without it automatically adding a note off each time my key is pressed , Is there a way to turn this feature off?

2 options seem to influence the behaviour of note offs set while recording.

In the sample properties “one shot”

or toggled preferences->midi->“section record&play filter”->note offs

seems to affect pc keyboard and midi as well