Keyboard shotcuts don't work

After I installed the pro version of Renoise all keyboard shortcuts don’t work anymore. I already did research the board to find an answer to the problem and tried everythig what’s described there:

I un- and reinstalled Renoise. I scanned my system for malware and deleted everything that was found. And I uninstalled every program I installed after the installation of Renoise Pro. But nothing really helps.

Has someone any other option I can check?

My system: Win 7 Ultimate SP1

There’s a professional version?

Weird. I’ve run into much the same thing. I’ve had Renoise running on Windows 7 pro for a while now, all running fine. Today I discover that the keyboard does not work. I don’t think it’s specific to Renoise; I have some other tools that should respond to special shortcuts (mDesktop, an very nice multidektop emulator) but suddenly do not.

Some Googling suggests that there is some other program running that is interfering or some other program or update altered some directx thing.

I tried reinstall Renoise, but no luck.

I thought perhaps it was a recent update of my Leap Motion software, and I uninstalled that, but nothing changed. I may have to reboot and try again.

It’s quite frustrating.

Worse, I had run low on disk space and Windows helpfully deleted all my restore points, so I cannot roll back to an earlier setup.

An update. There were some pending Windows updates, so I installed them, and rebooted. No luck with Renoise.

I did another uninstall/reinstall of Renoise. No luck.

The weird ting is that I can start Renoise and often the very first keyboard command will work (e.g. pressing Space starts the empty song playing, or pressing Esc toggle on edit/record mode) but that’s it. No additional keyboard action has any effect.

Any suggestions on how to resolve would be appreciated.

Next step is to restart Windows in safe mode.


A restart in safe mode with networking has Renoise keyboard working fine. Next step: selective start-up.

Are these specific keyboard shortcuts that do not work?
I am randomly trying a few here, but they all respond.
Even the ones i redirected to my windows keys for play and record. (I also had a few Windows updates).
So the update most likely isn’t it.
I suspect there must be some kind of malware or rootkit messing up or started messing up after those updates were installed.


Seems to be an issue with running Synergy as a Windows service. This was a disappointment to discover, but it turns out that running Synergy from the commandline seems OK. Odd, but good, since I rely on Synergy and starting it manually is minor thing.

It also has nothing to do with some Windows services I deactivated a few days ago. I putted some service states by mistake to “deactivated” and now some correctly back to “manually”. (I’m talking about services that are recommended to disable). But it doesn’t help to the problem with Renoise.

Also an update of directx.
System scan for rootkits: No result.
System scan with MS Tool to delete malicious software: Nothing found.

@vV: All shortcuts don’t work

Have you tried booting into Safe Mode and seeing if the Renoise keyboard commands work?

Hmm, I have the same problem but in Gnu/linux. The first keyboard command works fine and then nothing.
First thought it was my keyboard or something.

You mean this synergy:

Or something else?

Yes, that. Very handy if you’ve multiple machines running and want to use a single keyboard/mouse across all of them.

However, it’s a tad buggy; meta-keys (alt, ctrl, etc.) will get “stuck” on a remote machine every so often, and apparently it can interere with some, but not all, hot key arrangements (and apparently Renoise keyboard events).

I have this sometimes. Then I quit renoise and start it again, it’ll work.