Keyboard stops working when using plug-in

I just started messing around with plug-ins, and I find that as soon as I use my mouse to tweak parameters in a plug-in’s external editor window, the keyboard stops acting like…well, a keyboard. I have to click on the on-screen keyboard with my mouse, trigger a note, and then my hardware keyboard will play notes again. Is this normal? Is there anyway I can keep playing notes on my keyboard while moving parameters on the plug-in?

Thanks.

Maybe the plugin windows somehow grabs the keyboard input from Renoise.

Which plugin, operating system are you using?
And I’m assuming you mean a typing keyboard here, not a MIDI one?

In the lower left corner of the plugin’s external editor, you’ll see a checkbox marked “Enable Keyboard”. (Reference: http://tutorials.renoise.com/wiki/Plugin)

In situations where you need to enter text directly into the plugin’s editor, certain plugins require this “Enable Keyboard” option to be enabled in order for the key strokes to be picked up correctly. The downside of enabling this option is that the plugin will also steal other computer keyboard events, ie. attempting to play notes.

Is it possible that you’ve enabled this at some point, and simply forgot to disable it again?

Thanks for your assistance! I’ve tried running Madrona Lab’s Kaivo, u-he’s Tyrelln6, and Daichi Synth 1-2 on my iMac which is running OS X. I do not see the “Enable Keyboard” check box on the external editors, but I do see that it says in the bottom left hand corner on each external editor “No focus options for bridged plugins”. Is that maybe the issue? Also, what does that mean?

Thanks again!

Yes that’s probably it. I think it’s that you’re running a 32-bit plugin in the 64-bit version of renoise.

Actually, I do have the 32 bit version of Renoise running! I just double-checked.

Maybe you’re running a 64-bit plugin then? I think the bridge works both ways…

You have to disable sandboxing as well.

EDIT: sorry, Jurek, I didn’t see your message before I replied to pat’s last post. Yes, disabling sandboxing fixes the problem, thank you! But, just so that I am clear on this, that is the way it is supposed to work, yes? In order to be able to play a plug-in with one’s QWERTY keyboard, one needs to turn off the sandbox feature? That strikes me as a little weird because I thought the sandbox was somewhat of a novel feature. I remember reading that Bitwig had that, and everyone was impressed, except for those that knew that Renoise had it too. Doesn’t having to turn it off to play on one’s QWERTY keyboard kind of defeat the point? Also, it would be smart to mention that in the User Manual, I think.

Anyway, thanks Jurek, and everyone else, for your assistance!

The generic issue with having control of the computer keyboard lays in the way the operating system allow applications to gain control over it.
Within renoise, this can be done in a very smart way, but that no longer works if you are depending on external applications like plugins, since they have their own keyboard handler. The plugin developers should then also have written a keyboard routine that translate the note-key area of the computer keyboard into audio, which most plugins naturally don’t do.

That checkbox is nothing more than telling Renoise to either give the plugin window full keyboard focus or simply keep the focus on Renoise yet set the plugin window into a sort of modal mode (that is is always visible on top). And there are no more options regarding computer keyboard control that applications get from the operating system unfortunately.
Renoise is one of the fewer applications that actually supports the computer keyboard as an input device and as you now witness the limitations of this use, this is also a reason many audio applications rather have you use a Midi controller for it which really is the best option.
The Qwerty is merely a justified means if you don’t have the space or opportunity to use a midi controller like in a train…
But even that today seems no legal excuse anylonger…

This also bugs me, am I right that in the Linux version there seems to be no way to keep keyboard focus on renoise for keyjazz? Sandboxing on/off makes no difference in that no option for such handling is present, neither with dssi’s nor vst’s. I got used to keeping the plugin interfaces above the keyboard, clicking it to gain access to keyjazzes to test sounds I’m just tweaking.

And is sandboxing not a little overrated? Only real uses I could think of is to prevent broken plugins mess the host application, be it by stray memory access or by triggering exceptions. The latter could also be done without sandboxing by catching those, keeping track when they happen in the plugin code and not the host. Maybe even some security stuff, but that would probably rather esoteric improvements as the code is run as user on the system anyways.

Thank you for the thorough explanation. Yeah, I need a midi controller…