Launchpad Mini won't work with Duplex


(interposer) #1

I’ve followed all the instructions on Duplex setup with my Launchpad Mini, but can’t get it to behave the way it’s supposed to. No matter which launchpad configuration I choose, whether it’s keyboard or drumpad or sequencer, the lights look something like the attached photo, and it inputs like a keyboard except for the fact that the circle buttons on the right are counted as notes. The unlit buttons are still assigned to notes, but don’t light up when I press them. The Duplex documentation said that it handles MIDI I/O separately, and as such will work with the MIDI device of choice disabled in Renoise’s MIDI preferences, but it doesn’t play notes with the device disabled in Renoise, which would lead me to believe Duplex wasn’t receiving the inputs at all, except for the fact that the squares light up on the Duplex browser when I hit the buttons. I selected “Launchpad MK2” for both input and output device in the device configuration. I’ve tried this on two different computers at this point and gotten the same exact problems. I’m running the latest version of Duplex on Renoise 3.1 64bit on Windows 10, in both cases.


(danoise) #2

To fix the color representation, I would need to create a “driver” class which understands the LP Mini (I believe it has a larger number of possible colors).

But this is just a visual thing, which doesn’t affect the actual functionality.

For the LP to work as it’s supposed to, you’ll will you need to disable the device in the Renoise MIDI prefs (as you have already done), but also enable the OSC server in Renoise

(preferences > OSC). It should nag you the first time - I am guessing you clicked this warning message away?

Also: in the tool menu > Duplex, you can bring up the Duplex options from which you can test if the OSC connection is working.


(interposer) #3

To fix the color representation, I would need to create a “driver” class which understands the LP Mini (I believe it has a larger number of possible colors).

But this is just a visual thing, which doesn’t affect the actual functionality.

For the LP to work as it’s supposed to, you’ll will you need to disable the device in the Renoise MIDI prefs (as you have already done), but also enable the OSC server in Renoise

(preferences > OSC). It should nag you the first time - I am guessing you clicked this warning message away?

Also: in the tool menu > Duplex, you can bring up the Duplex options from which you can test if the OSC connection is working.

Thank you for your help. Since posting this, I started using Bome MIDI Translator and making my own custom modes for it, and I’m having so much fun programming it myself, getting Duplex to work is no longer a priority. For the record, though, I did set up the OSC server, and it’s actually not a Launchpad Mini; I got it for Christmas, and assumed it was the mini because the person who gave it to me said it would have been more expensive to get a larger one. But looking at the packaging, it appears it’s a standard Launchpad MKII.


(danoise) #4

I started using Bome MIDI Translator and making my own custom modes for it

Cool. Have fun !!