Line-in Device / MIDI Instruments Timing, Pdc, Latency

Tested with R2 RC1 on Vista 64bit

Scenario

  • Open project with some VST plugins and effects
  • Add a new track with a line-in and track some notes in rythm with an instrument assigned to the line-in’s corrosponding midi channel
  • For the sake of this test put ASIO latency on 528 samples / 12msec.
  • Play track with PDC on and off

Result

  • Project sounds okay with PDC off as 12ms ASIO latency and all the plugin timing feel in sync
  • Turning PDC on will make all VST channels run perfect, but the PDC correction seems to be added to the ASIO latency on midi devices routed over a line-in, making them sound way out of beat sync. Looking on PDC info I assume it probably corrected -15ms, making my synth run with a +27ms latency)

I suppose a workaround might be to time it by correcting the delay by hand in midi instrument properties, which is not a charming solution, as I figure adding VST may change the PDC correction and make me update the delay on up to 16 midi devices every time that happens.

Or another workaround is obviously disabling PDC. Not a solution I dig though, as the new PDC feature seems to make our HardSID4U device / VST combo run so smooth! :) ( Or at least it had a horrible latency in R1.9, which is gone since R2 beta )

I’d suggest the best way would be if the PDC correction gets applied to either the line-in or the midi instrument, if that’s possible?

It’s a delay you’re stuck with and have to know if PDC is engaged. I record audio all the time so it’s the same issue there - I have to manually cut off three things from the start of the recorded sample:

-ASIO Latency +
-ADC latency +
-PDC latency per song
= Amount to compensate in samples for accuracy.

To an extend you can specific this is audio recording in the sample editor but it’s STILL in MS not samples! So I’m left to cut hundreds of recordings by hand, every time.

Both my post and your post are [nonbug] and are ‘feature discussions’.

Aw didn’t know there was a discussion on this already. Suppose I didn’t search hard enough, or for the wrong terms…

Anyway. I’ll live without PDC, when not using the Hardsid device… It’s just, I think the PDC feature can be perfect if it applied its correction on plain midi instruments as well.

I mean it seems hardware that comes with a VST works fine with PDC, as the VST is corrected by it. So you only have the added ASIO latency on your line-in (which is normally only 2 to 5ms max in our setup)

But with plain midi instruments and line-in, PDC adds up. Just wondering if that could get fixed somehow…

Now where is that other thread… :P

Renoise do compensate midi as well.

Are you sure you have picked the correct settings?

If you return the external midi device as Line-in signal in renoise you have to choose “Line-In Return” in the Midi Properties for that instrument. You also have to change the setting in the Line-In Device to “Midi-Return Mode”.

As pysj said: have you set up the LineIn Device and MIDI instrument to reflect your setup? In case you’ve missed those settings, what could we do to help other not to miss those settings.
There is no way to auto detect what you do with MIDI instrument, so there have to be some options somewhere that define how and which latencies are applied. We already tried to describe those as easy as possible. Anything else we could do to make this more fool proof?

Alright, that was it. Nice! And thanks :)

Hmm, about the fool proof thing: now that I know it is there, it makes sense. I really have no clue what could be improved about the current implementation. I just wonder if I could have found the solution to my problem myself by reading the manual, if not thinking this was a bug to do with the new PDC implementation and all. Hard to test that out now, since I have a clue where to look now :P

The only way I can think of when thinking about ‘full proof’, is going the setup wizard way. Like someone sets up a midi device and renoise shows a box with the latency stuff explained and what each setting does and make the user choose one. Of course with a little checkbox with the ‘don’t show me this wizard again’ kind of option.
I don’t know if you want to go that way and I think many advanced users will find it annoying to get a wizard for anything (be it one time only), but that’s probably the only tried and true way to deal with new and inexperienced users.