Linux - Calf plugin meters do not work (DSSI)

I use the Calf plugins in Linux because there is a DSSI version but there seems to be a problem them, they work except the meters in the gui do not work, they show no audio levels or changes at all even when the plugin is active and working. I have tested the plugins in other apps such as Carla and Qtractor and they work fine in those so it seems it is a Renoise issue.

I run Manjaro Linux 64 bit and use Renoise 3.0 64 bit. For the calf plugins I use the kxstudio fork available either from or through the kxstudio repos or from AUR. The plugins say that the version is 0.0.19 but they are the latest version from kxstudio.

  • What exactly have you done to “create” the problem?
    Not much is needed. Start a new song, create some audio, load the calf compressor or limiter or any of the plugins with level meters and notice that nothing shows in them, the audio is processed but meters don’t work, compressor input/output/reduction meters are useless.

  • Can this issue be replicated in a clean & easy environment such as an empty song?

  • plugin compatibility
    I tried all three options as well as disabling all three and it didn’t make any difference.

Just me then?

I assume you use 64-bit of Carla and QTractor as well?
I’m not sure if the calf plugins you use are compiled 32 bit, if so, they may perhaps work because you may have some of the 32-bit libraries installed, but if they are 32-bit, how do they work when trying them in the 32-bit version of Renoise? (Unbridged in this case)

Yes, I believe Carla and Qtractor were the 64 bit versions as well.
I just tried 32 bit Renoise but the same thing happens, they show no meter movement.

I’m not sure about this one. I know there have been other complaints about the calf plugins but i can’t remember that this regarded GUI issues (In fact they were not working at all so you can at least cross your fingers you can do something with them)