Linux Frustration

Ok, first of all, I’m a complete Linux n00b. I installed Ubuntu 8.04 two days ago (and before that I have only done some coding in gedit through putty on a linux box at my university.)

Basically I’m very happy with Ubuntu. I have my Firefox, my vlc, my open office and I even got uTorrent to work with wine. I have also installed Renoise and it worked fine with the ALSA driver right out of the box.

Now to the problems:

- How the f*** do I get VST instruments to work in Linux?

When I look around I get the impression that there are tons of VSTs that work in linux but I haven’t found a single page that explains how this is achieved. Usually all you get is something like “works great with wine and wineasio”… ok, I have installed wine and wineasio, then what?. Example: Linux Vst Compatibility

To me the whole linux community seems so cluttered with half-ass guides and dead end forum threads. I basically can’t find anything of use no matter what search string I feed google with. I haven’t felt this clueless about anything computer related before. :angry:

First of all I would like to be able to use the oatmeal vsti, so if anyone knows how to get it running in Renoise I would be very grateful.

- Why do I get crackling playback when using JACK in Renoise?

This may be a easier question to answer… By crackling I mean like when you set your latency to low in win-version Renoise.
I have JACK Control installed and I have tried to tweak some settings but I have had no luck so far.

[Edit] I should mention my hardware:
HP Laptop - Celeron 1.8GHz, 1GB RAM, Intel 945GM Chipset

it’s not exactly a powerhouse, to say the least…

this article has a section regarding plugins (“Setting up third parties plugins”) which explains how to use VST plugins which have been compiled for Linux platforms.

the URL to which you are referring explains instead how to use Windows VST into Linux, which is a completely different and much harder topic, explained in this thread expecially for Renoise users.

You may be getting crackling audio with low latency settings particularly if you are using the standard ubuntu distro without the realtime kernel. Ubuntu studio 7.10 is what i use without problems. (although i can get crackles if the latency is too low).

Vsts, ive had various amounts of luck… some work fine, some crash, some have graphics troubles.

Theres a few compiled for linux here…

Dont forget to register your plugin path for renoise.

I’ve had Disco DSP highlife working fine, as does peggy2000 (sadly the filters are poor)
Never been a big vst fan myself though, but a Distrobution where vsts worked with no set up was Demudi, perhaps you can get your hands on it if you have no luck.

Thanks to both of you! That was exactly what I was looking for and 5 minutes after reading the guide I had synth1 up and running in Renoise. I could not get oatmeal to work with fst however but strengthened by the experience with synth1 I dared to go on and try out the dssi method and with my newly acquired linux skillz I was able to get oatmeal to work, with preset loading features as well! :) Weeee!

I have downloaded the Ubuntu Studio 8.04 iso file and will try it out tonight. Thanks for the tip!

oh hey the RT kernel is loaded at boot with grub.
when you boot you should have an option to look at grub lookk at it an it should be at or near the top. if they havent changed that in 8.04

er i meant to say, i think you should already have the RT kernel.

Yah, i got the realtime kernal, i should have mentioned you increase your latency or buffer size in jack control panel…
FRAMES/PERIOD will affect latency and performance too… but i just fiddled, rather than really knowing what i was doing with this bit.

Just wanted to thanks you guys and let you know how things went.

I installed Ubuntu Studio 8.04 and got everything working with Renoise and JACK. I had to set the Periods/Buffer to 4 and voila, no crackling sounds anymore. The realtime kernel really did the trick!

…however, I started to get strange system wide slowdowns. Everything from starting up the system to moving around windows, opening drop-down menus and typing in the terminal took forever. Just starting up the system took over 10 minutes. I was convinced that it had something to do with some process taking up all the system resources by taking advantage of the realtime capabilities. Occasionally things would normalize and I could use the computer without problems. I couldn’t figure out what was going on so I decided to reinstall a fresh Ubuntu studio copy and be really careful when installing extra packages. I popped the DVD into the tray and restarted the computer. At that point I knew something else, much more sinister were plaguing my system. Even the installation was slow, with distorted graphics and half hour long hangups. Furter investigation was required so I found an old UBCD (Ultimate boot CD) and did a couple of tests. Everything seemed to be working fine, only very slowly… The Intel CPU Identification Tool showed something weird though… “Expected frequency: 1733MHz - Detected frequency: 166Mhz” :blink: Apparently my Celeron has been downgraded to a Pentium II…

I took my laptop apart and used compressed air to remove dust and possible metal particles that could be bridging some connections that shouldn’t be bridged. Nothing seemed to help though. I was completely baffled and started to suspect that maybe Ubuntu Studio came with some weird power saving “feature” that had somehow locked the bus or multiplier on some crazy low setting by frying my mobo… :ph34r:

Lets install Ubuntu 8.04 again, I thought. Evrything worked fine until I installed the Studio edition… After about 5 hours of reinstalling I was back were I started. The system was still sloooooow. That’s when it hit me, “THE BATTERY!” WHY THE HELL DIDN’T I THINK OF THE BATTERY???

I found the source of my problems shortly after… but it wasn’t the battery. It was actually the AC adapter that was very glitchy. or rather the cord from the AC adapter to the computer. Most of the time it wouldn’t connect properly and my PC didn’t get the juice it needed so it underclocked the processeor. When I bumped into the desk however, or moved the cable slightly with my foot it would make a proper connection and that’s when I would have those periods when everything worked as it should. I had a spare ac adapter so… problem solved! :)

Sorry you had to read all that (…nobody had a gun to your head) but maybe you learned something from it. I sure did. I would never have thought that a powersupply that faulty could produce those symptoms.

Anyway… I dropped Ubuntu Studio and now run the ordinary Ubunu 8.04 distribution with the RT kernel. Studio was ugly anyway and setting up JACK and everything else manually has only been good for me.

sorry to say this, but your issue was quite fun to read :)

welcome back to realtime tracking, though

Sounds particularly unlucky
Be careful with that compressed air… you could end up with dust all over the place.