Linux: Helm GUI shows as corrupt in 3.2

The VST Helm’s GUI is not drawn properly for me on linux with 3.2, it displays garbled squares and seems to have a tendency to crash renoise. Same version of helm is fine on 3.1.1.

Follow these steps:


This should be reported to the author of the VSTi.

Helm looks like abandonned now.

Helm indeed is behaving super weird here. I’ve got no clue why. It’s broken in HiDPI and without the HiDPI plugin compatibility mode enabled. But as Raul already mentioned, this can only be debugged and fixed in/by the plugin authors.

Helm is open source isn’t it? Maybe someone else continues the development?

Just for completeness, worth mentioning what Linux distro/window manager you are trying the plugin with?

Quick thought: That Helm looks like it uses the JUCE framework -> https://github.com/mtytel/helm Do other open source plugins (that use the JUCE framework (particularly if they render the graphics with OpenGL?)) look okay?

I don’t have that option in the [?] window, is it just a Windows thing? (Not sure why the thread title was changed to Windows, that’s not what I’m using).

@taktik I will report it to the author. I would be surprised if the synth is abandoned, I know Matt was working on another synth so he might be focusing on that at the moment.

@4tey I am using Neon (Ubuntu 18.04 with KDE). I don’t know of any others that use JUCE although I have a JuceDemoPlugin which loads fine. A quick search of my system found the source of Tunefish4 which seems to use JUCE and OpenGL, it loads fine in 3.2.

Okey cokey. I’ve tried Helm 0.9 with Cinnamon window manager (simpler wm)/Linux Mint for you and it seems to render the GUI fine here.
There is a standalone version of Helm in the .deb download that I have here, I don’t know if you can find and try that? I don’t know if you can disable compositing through KDE as another thought.

Interesting, the standalone works fine for me, as the vst also does in reaper.

I tried turning off compositing but it didn’t make any difference (I don’t know if it was actually off though). However, I installed AwesomeWM and helm works fine in renoise there so it would appear to be compositing related.

1 Like

Try the following: Press the [?] button of the plugin in Plugin tab…
image
@Meef_Chaloin. The [?] Button does not appear in the Linux version? I can confirm that it does appear in the Windows version.

When you click on that button, a “Plugin Options” window appears. And there is the Auto-scale checkbox. I find it strange that Linux does not have this option.

Maybe this button is a little “hidden”, and you haven’t seen it until now?

I believe that “the famous” [?] button for the plugin is available for all three operating systems.

Don’t know if it has something to do with what is said here (► Renoise 3.2 & Redux 1.1 released)?

  • Linux: As far as we’re aware, there’s no way to automatically upscale non-HiDPI-compatible plugins. So if a plugin doesn’t support UI scaling it will appear small on HiDPI screens (the Renoise GUI will still scale properly).

Yes, this is only available on Windows. On OSX the HiDPI support of plugins is detected and applied automatically. On Linux there is no autoscaling applied at all by the system.

1 Like