Linux: Only one Core on an Athlon Dual Core system recognized

Hi all,

my problem is, that renoise doesn’t recognize my system as a dual core system, and it is not able to create a realtime thread.

Here are some things I consider useful information:


  • AMD Athlon™ 64 X2 Dual Core Processor 5000+


  • Ubuntu 8.04.1 (32 bit)

Linux ubuntu 2.6.24-19-386 #1 Wed Aug 20 21:59:50 UTC 2008 i686 GNU/Linux

rtprio of the realtime group (in which my user is in):
hard: 20
soft: 10
(set in /etc/security/limits.conf and verified by ‘ulimit -r’)

I am able to start JACK in realtime mode.

So the symptoms are seen in the log file when started:
Renoise LOG> CPU: Found 1 enabled unit(s) with 1 core(s) / 1 logical processor(s) per unit. 1 cores are enabled in total.
Renoise LOG> System: Failed to create a RT thread. Trying again as FIFO thread on process scope…

Any ideas?


20 / 10 is awfully small. Maybe renoise tries to aquire higher priority?

Thanks Suva. (should have thought of this myself, actually ;))

So with a rtprio of 100, renoise seems to be able to create an rt thread. Does anyone know, how much is needed exactly? I could do a manual binary search for the minimum value, but if anyone knows, it would make my life easier ;)

So the only problem, that till exists is, that renoise doesn’t recognize my second core.


Try out which works best for you. Too high priorities can actually lead to lower perfomance. But I would try something around 60 - 70. I don’t think renoise raises the limit itself. So you can set the hard limit to 100 and then modify the real limit (soft limit) with ulimit before starting the renoise. If you find out what works best for you then put it to /etc/security/limits.conf

For the cores: Check Renoise preferences: “Realtime audio CPUs” setting. Set it to 2.

If you can only select one from there, then check if other programs can see two cores. If not, make sure you have kernel with SMP in the name:

$ uname -a
Linux suvand 2.6.24-21-rt #1 SMP PREEMPT RT Mon Aug 25 19:24:40 UTC 2008 i686 GNU/Linux

MarvelousMarvin: Have you checked your kernel version as suggested by Suva? Guess Renoise 1.9 behaves the same way, right?

oh… sorry for not replying. I missed Suva’s reply. :confused:

As far as I know it isn’t necessary anymore to use a special kernel for multi core support (but I may be wrong). I am sure, that I am not using a special SMP kernel at home, but I will do some checks, when I come home, to provide you with more info (other applications, renoise 1.9 etc)…

You don’t have to have special kernel. You just need SMP support compiled in. Some kernels still don’t have it, and thus use only one core. If you have this SMP tag in there, but it’s still not working, you may also provide the contents of /proc/cpuinfo which may be some help for finding the problem.

By having a look at /proc/cpuinfo I recognized that my kernel is indeed only seeing one core.

I then had a closer look at my kernel version and “doh’”! It was my fault. I had a weird kernel installed (god knows, why i had the 386 installed). Now with the generic one, everything is fine.

Sorry for bothering you with a [nobug] and thanks for your replies and help.

MarvelousMartin: Don’t worry about it, this tip could probably come in handy in the Linux HowTo

We’re not really another “How to setup Linux from the ground up” guru-clan. This is a Linux specific thing that has nothing to do with Renoise.
We’ll just answer that stuff here and it will be alright.

In the past you also required a special SMP kernel for Windows.
Those days are over now.

Yay. Nothing to sorry. Linux setups can be confusing & complicated. Moved to the help & support forum, as others might have this problem as well…