Linux: Renoise 3.2.1 final using too much cpu

I just try 3.2.0 and cpu it’s much less than this new version? Didn’t have any problems with cpu until I’ve updated this new version 3.2.1 final released. Everything in the setups are same, midiplugins, vst, etc.

I don’t see any difference here with Debian 10.

Aaahh ok…in Ubuntu Studio it’s using more cpu…i’m running Renoise also with Mint but that’s version is that 3.2.0. Maybe the low latency is causing more cpu?

You have to compare the version on the same computer with the same material, otherwise it makes no sense at all.

Yes I know and they are in same pc, only different partition.

in many daw’s the problems is that the cpu is overloaded very easily, my computer is not new but still have 8 core processor over 3GHz and 12Gb ram. I can still editing videos better than make complex, multilayer music. So it really makes me wonder do I still need new, better, faster computer? Maybe…

Also make sure that the CPU governor is set to “performance”. This makes a huge difference for CPU intensive realtime apps.

Yes, I know also that and I have that. That helps. I have this other pc with 6 core cpu and it is there now also…cpu freq…

Have you enabled “realtime priorities”? The terminal command “ulimit -r” can show what is set up (it will not change anything), it should be set higher than 95 I think.

I have 95

95 should be okay, there must be another problem going on then…

Ok…but somehow now everything works very well. Maybe this cpufreq tweak what I did few times, I just change from performance to powersafe and more. Now I keep “performance” always when I work. So now it works well. :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.