Linux: Renoise With Alsa Hangs After Suspend

Hi

If I have my laptop suspend with renoise started, it eats 100% cpu after a resume. It only happens with alsa, when running jack, both jack and renoise survives the resume just fine…

yeah this is one quirky aspect of linux on laptops. You’ve got to tune everything just right.

I’m assuming this is for your arch system…
How much RAM do you have vs how big is your swap disk? Is compression enabled in your /etc/suspend.conf?

https://wiki.archlinux.org/index.php/Suspending_to_Disk_with_hibernate-script may help.

First: I only briefly looked at the page you mentioned…

But I’m talking about suspend (to ram) not hibernate (to disk). Secondly, jack survives the suspend just fine, as does other ALSA apps, like transcribe. If I were to look for a hack, I’d expect something alsa related, not something related to the actual suspend process itself, but I might be wrong… Best solution would of course be that Renoise would handle this for me :slight_smile:

Sorry for the bit of necro posting here…just a tiny bump.

I just happened to suspend Arch Linux here with Renoise 3.2b1 ALSA. Yes, after resume Renoise audio does freeze and consumes 100+% cpu on a thread(s). Luckily the GUI doesn’t stop and I find you can go to the preferences and reinitialize the driver.

I don’t know if this is a Renoise thing or not because I’m not a fan of suspend/resume with Linux (don’t know what the stability is like with Windows), but it is convenient. However of course if other ALSA audio driven programs are fine with that suspend/resume cycle then it points more to how Renoise is handling it (or not).