Linux: Touchpad Synchro lost On Debian Etch When Resizing

Hi to the great team! :guitar:

When i’m resizing Renoise, I always have a Touchpad lost synchro…

I’m using a 2.6.26.6-rt11 kernel, it was the same problem with older kernels…
i’m using Windowmaker.

I don’t really know if it is a problem from the kernel, or from Renoise…

I’m not using WIFI connection (i know on some distributions as Ubuntu, there was the bug using WIFI).

I don’t have this kind of messages with other applications.

#dmesg

psmouse.c: TouchPad at isa0060/serio4/input0 lost sync at byte 1
psmouse.c: TouchPad at isa0060/serio4/input0 lost sync at byte 1
psmouse.c: TouchPad at isa0060/serio4/input0 lost sync at byte 1
psmouse.c: TouchPad at isa0060/serio4/input0 lost sync at byte 1
psmouse.c: TouchPad at isa0060/serio4/input0 - driver resynched.

:drummer:

Hi BreemiX,

is there really a problem or do just you wonder why this is only logged when resizing in Renoise? When there is no problem we don’t really need to worry about this, right?

Hi TakTik,

thanxs for the reply.

It is not really a problem because I usually work in FullScreen Mode…

But I wanted to ask, because on some configurations, with some applications, there is this kind of bug, and we never know if it is a kernel bug, or an application bug…

But on my config, just Renoise gives me these kernel messages…

Does somebody else have these kernel messages?

Regards

:drummer:

Is there something wrong with your touchpad afterwards? Aka, is there really a problem or do you just wondered where the messages come from?

If there are no problems, lets please ignore this…

Hi from there!! :guitar:

There is no problem with the touchpad afterwards,

just have to wait 1 or 2 sec for the synchro comes back…

But I just wanted to ask about it.

As I read on some forums, some people loose their touchpad synchro when they are using a WIFI connection, but other people like me have this kind of bug, on some applications… (just Renoise in my case)

When compiling a new kernel, I saw on forums that enabling many touchpad drivers in the .config file could resolve the problem… Some people say that it is a kernel bug never resolved…
I didn’t do that, just enabled for my touchpad…

So that is a strange bug, and I never saw a good solution…

If you know a lot more , please, tell me from where the messages are coming !!

We can ignore this, Renoise Rc1 works very good here.

Regards,

BreemiX

:drummer:

No, sorry. This doesn’t happen here so I don’t really have a clue how to test this.

Maybe someone else here has an idea?

It is also the same when i move Renoise in window mode.
It is the same under Gnome.
It is the same with the video ATI proprio drivers.

It couls be great to have an embedded window for Renoise, like other applications.

It is not a crucial bug, but could be when using other audio applications at the same time…in live mode…

Regards

:drummer:

I suggest that adding windowmanager borders could be a command line switch or configuration option.

When running compiz we already add the default window decoration/border to get rid of various compiz related problems. I hoped we could avoid this, as this looks disturbing and ugly with the rest of the Renoise GUI.
Dunno, but this looks more like so far uncovered bugs in Linux as usually window borders are used by applications? A command line switch would be possible, but I would prefer to automatically add it when needed. Is there a way to find out if its needed?

I have no idea what this “touchpad synchro” is supposed to be and why renoise loses it. But apparently you can grep through dmesg. ;D It sure looks more like a bug from kernel side rather than renoise side. One GUI program shouldn’t cause problems with the kernel driver of one way communication (input) device. Seriously.

But the option to show window borders may actually not be that bad idea. As it would probably resolve some bugs with exotic window managers. (Which WindowMaker is). There are plenty of those around and some linux users are keen on using the least supported of them. :)

  • 1000 for me!!

I have tested again this morning and took a little screenshoot…

When I resize Renoise very slowly, the window is correctly redrawed…

When I go normal speed to resize, the window keeps the border pixels shown on the pic, on bottom and right side.

Bordered pixels are tested on Etch and Ubuntu 7.10 Gutsy, both Windowmaker and Gnome.

The loosed touchpad synchro kernel messages and the bordered pixels are present with Renoise 1.9-1/2RC1.

The Gutsy is on a Desktop computer with a normal mouse, but sometimes gives me eratic things when moving all the Renoise window…the window is moving alone for half a seconde, going in the direction of the bottom right of the screen…it happens just after moving fast the window everywhere in the screen, then unclick the mouse button…it is not systematic, but I can reproduce the ghost bug!!! lol!!!
Or maybe Renoise’s brain is too much active!!!

After that, Renoise is still working…

Hope it help!

:drummer:

I need it!!! :D

:drummer:

Windowmaker exotic? :panic:

http://www.windowmaker.info/faq.php?chapter=8

:drummer:

Yes it is. Gnome and KDE windowmanagers are not exotic. Rest of them, pretty much are. Specially counting that wmaker hasn’t seen active development since 2005.

Because it is finished!! lol

Gnome, kde, compiz, etc… -> very big code, slow, full of bugs and exotic things for lazy people.
wmaker -> small, light, simple, essential, no bug. (except with Renoise, as with Gnome and KDE… :D )

:drummer:

Well, there is no point in arguing over what windowmanager is better. I hate those discussions. As a matter of fact I am also a long time user of wmaker, switched to gnome only recently.

The fact that I can’t reproduce this bug on any of my systems seems to show it’s rather a problem with hardware or drivers.

I’m sorry for the troll, but I think in this case, it is important.

I have a GUI bug here with 2 different systems and computers, with recent kernels (2.6.26.6), and older.

The resizing bug comes with Gnome and Wmaker, on both computers.
Did you have a look on the pic I have posted? Strange, isn’t it?

As I told in a precedent post, the lost synchro dmesg could come from a kernel bug, or not… I have never found a good answer, excepted to compil the kernel with all the touchpad drivers…On my notebook, I have tested with the ATI proprio drivers, and with the Etch distrib packages, and it is the same.
On the Desktop machine, tested with NVIDIA proprio drivers.

But maybe we have 2 different bugs :

  • one from the kernel for the lost synchro.
  • one from Renoise with the GUI gestion.

I think that having an Embedded window for Renoise could be a great choice.

:drummer:

Tested on Ubuntu Hardy with the last Generic Kernel on my notebook:

  • No more DMESG Messages when resizing Renoise!!!
    But i have the same strange ghost bug (Renoise is moving alone when i try to resize it) that I have on my Desktop computer (with a normal PS/2 mouse).

  • Still have the bordered crazy pixels on bottom and right side after resizing Renoise. :panic:

:drummer: