Linux: Trouble installing Redux; unstated dependencies

I’m trying to install Redux for 64-bit Renoise 3.0.1 on Linux.

I defined an environment var VST_PATH, placed the Redux files (the 32bit and 64bit folders) in that folder, updated my resourced my profile files, and loaded Renoise.

I get a popup message with this:

Failed to initialize the audio plugin server: Failed to resolve the font file for font DejaVu Sans.

I have DejaVu Sans on my machine. It’s also part of the Renoise 3.0.1 installation.

I have no other VSTs or plugins.

To be sure that the message came from Redux I closed Renoise, cleared my VST_PATH folder, and started Renoise again.

It gave me a message about a previous issue and said it would not be loading Redux (though the Redux files were no longer in the VST folder).

I closed Renoise, then reopened it. No messages, all looked good.

I closed Renoise and copied just the 64bit folder contents to my VST_PATH folder (since I’m only running 64 bit Renoise)

I get no error messages, but I see no sign of Redux.

The Redux quick start manual says “When launched, the plugin will be in Compact Mode, …” but says nothing about how you actually launch it. There’s nothing to let you know if you’ve installed Redux correctly.

I just checked my Renoise log, and found this:

VstPlugs: Trying to instantiate /home/james/VST/64bit/renoise_redux.so
VstPlugs: Instantiate FAILED (failed to open the DLL: ‘/lib/libm.so.6: version `GLIBC_2.15’ not found (required by /home/james/VST/64bit/renoise_redux.so)’) !!!

But there was not error message show to me. I found nothing on the Redux Web page mentioning system requirements.

Renoise 3.0.1 runs just fine on my admittedly older Ubuntu (10.10) so I assumed Redux would too.

I understand (i.e. gotten used to) not being able to run more recent software because of assorted system library requirements, so if I really can’t run Redux on my version of Ubuntu I can live with it.

However: Is there a way for me to get this to work (aside from updating my OS)?

Can these system requirements by made known on the Redux sales/download page?

I suggest adding a decent error message for such Redux loading errors as well.

I can’t fully answer your questions re:Linux, since I’m not a Linux user myself and I know very little about tweaking the OS/libs/etc. Hopefully taktik can chip in with more info on that front.

I see no sign of Redux.
The Redux quick start manual says “When launched, the plugin will be in Compact Mode, …” but says nothing about how you actually launch it.

Redux is a plugin instrument, so you load it in Renoise like you would any other VST plugin instrument, via the Plugin tab.

http://tutorials.renoise.com/wiki/Plugin

Granted, if you’ve really never used any form of plugin instrument in Renoise before, then it’s understandable that you might not already be aware of the loading process.

I found nothing on the Redux Web page mentioning system requirements.

The requirements are mentioned on the demo download page, and on the full system requirements page which links from there.
http://www.renoise.com/download
http://www.renoise.com/products/redux/system-requirements

Admittedly, the info could also be mentioned more clearly on the Backstage area, but I guess we sort of assumed that people would have successfully tested the demo version before ever getting that far.

I can’t fully answer your questions re:Linux, since I’m not a Linux user myself and I know very little about tweaking the OS/libs/etc. Hopefully taktik can chip in with more info on that front.

Redux is a plugin instrument, so you load it in Renoise like you would any other VST plugin instrument, via the Plugin tab.

http://tutorials.renoise.com/wiki/Plugin

Granted, if you’ve really never used any form of plugin instrument in Renoise before, then it’s understandable that you might not already be aware of the loading process.

I had tried some plugins before, so I looked in the plugin area after installing Redux. Not seeing it while also not getting error messages made me wonder if somehow Redux was different and would be found elsewhere.

The requirements are mentioned on the demo download page, and on the full system requirements page which links from there.
http://www.renoise.com/download
http://www.renoise.com/products/redux/system-requirements

Admittedly, the info could also be mentioned more clearly on the Backstage area, but I guess we sort of assumed that people would have successfully tested the demo version before ever getting that far.

Ah. OK, thanks. I went straight to purchasing since Renoise is colossally cool; while I’m still unclear what Redux can do for me I figure it, too, is likely colossally cool and would discover uses for it.

And I can run it on Windows if all else fails.

I’m going to try a 32-bit version of Renoise since I have the system lib in question, but for 32-bit stuff.

Thanks again.

I gave up on trying to install 3.0.1 32-bit. I already have 64-bit 2.8.2 and 3.0.1 and the Renoise installer is not set up for multiple versions and such. I hacked around the other versions’ installers to keep them form colliding, and for whatever reason whenever I try to run the 32-bit rns3 it just quits with “Caught signal 11. Terminating…”

But that’s a whole other thing, and not a problem I want to solve. I’m going to play with Redux on Win7 now.

VstPlugs: Instantiate FAILED (failed to open the DLL: ‘/lib/libm.so.6: version `GLIBC_2.15’ not found (required by /home/james/VST/64bit/renoise_redux.so)’) !!!

This is the problem. The version of Linux (libc) that you’re running, is older than the one Redux requires (was built with). Which version/distribution of Linux are yu running/have you tried this on?

I gave up on trying to install 3.0.1 32-bit. I already have 64-bit 2.8.2 and 3.0.1 and the Renoise installer is not set up for multiple versions and such. I hacked around the other versions’ installers to keep them form colliding, and for whatever reason whenever I try to run the 32-bit rns3 it just quits with “Caught signal 11. Terminating…”

If your Linux is 64bit, use the 64bit version of Renoise too. Everything else will very likely cause a lot of problems. Running 32bit apps in 64bit Linux systems is getting more and more deprecated and broken, cause most apps are available as 64bit apps.

You also don’t need to hack/modify the installer scripts. Multiple versions of Renoise are installed side by side already. The only thing which is overwritten is the “renoise” link in /usr/local/bin, which always is replaced with the most recent Renoise version that you’ve installed. If you want to launch a specific version, launch it via “renoise-X-Y-X from /usr/local/bininstead (XYZ is the version number)”

This is the problem. The version of Linux (libc) that you’re running, is older than the one Redux requires (was built with). Which version/distribution of Linux are yu running/have you tried this on?

As I said in my initial post, I’m using Ubuntu 10.10. Yes, it’s quite dated. But Redux was not giving me any error messages when Renoise tried to load it; I only learned of the library mismatch by looking at the logs. I’ve gotten used to things not playing nice with my 10.10 laptop. The lack of an error message was bit frustrating though, especially since the quick-start manual says nothing about how to verify that an installation was successful.

If your Linux is 64bit, use the 64bit version of Renoise too. Everything else will very likely cause a lot of problems. Running 32bit apps in 64bit Linux systems is getting more and more deprecated and broken, cause most apps are available as 64bit apps.

As I said in a previous post I am running 64-bit 2.8.2 and 3.0.1 Renoise. I do have some some 32-bit programs running as well, and was curious if running the 32-bit Renoise 3.0.1 would let me load the 32-bit Redux plugin. Getting the 32-bit version of Renoise to run turned out to be more trouble than it is worth to me. (There are a surprising number of programs that still only come in 32-bit versions. It can be frustrating, but it’s not that unusual.)

You also don’t need to hack/modify the installer scripts. Multiple versions of Renoise are installed side by side already. The only thing which is overwritten is the “renoise” link in /usr/local/bin, which always is replaced with the most recent Renoise version that you’ve installed. If you want to launch a specific version, launch it via “renoise-X-Y-X from /usr/local/bininstead (XYZ is the version number)”

I had to hack the script to have it do a local install and not require me to run it using sudo. I prefer to avoid sudo whenever possible. And I don’t want the default symlink for renoise changed (though that’s easy to fix after the fact)

As I said in my initial post, I’m using Ubuntu 10.10.

Sorry, missed that. Next version (update) of Renoise will also require 12.0 (GLIBC_2.15 or newer).

Is there a specific reason why you are using such an old version of Linux? We thought that Linux users in general would prefer more recent versions. 10.10 is from 2010. 12.12 is from 2012, which we assumed to be old “enough” for compatibility.

Sorry, missed that. Next version (update) of Renoise will also require 12.0 too.

Is there a specific reason why you are using such an old version of Linux? We thought that Linux users in general would prefer more recent versions. 10.10 is from 2010 years old. 12.12 is from 2012, which we assumed to be old “enough” for compatibility.

I tend to keep to what I have because (for the most part) Stuff Just Works. Inevitably, when I upgrade a distro, I find that some program I liked is gone, or “improved” to the point of being crap. And I can’t install older versions (typically do to library issues).

Things that work now, like hibernation and suspend, will fail. Most of what I’ve been using the machine for (software development, Web stuff) has been fine.

I realize that inevitably I’ll need to move on, but so far I’ve not run into the unavoidably compelling reason.

I had 12.04 on a desktop machine, which I recently rebuilt. I decided to just install Ubuntu 14.04 on it. Mistake. I’m going back to 12.04. Too much broken behavior for me on 14.04 (I’m using Trinity TDE so it’s not completely the fault of Ubuntu.)