Linux - Troubleshooting USB MIDI keyboard connection


Eager new Renoise user here. I have it running smoothly under Linux (Crunchbang) x64 with Jack and Alsa.

I have one remaining issue - a funny problem with my MIDI controller - an AKAI LPK25 mini USB keyboard.

When I first connected it, it was recognized straight away by Renoise and it worked perfectly. Happy days!.

However, after subsequent reboot, Renoise is no longer receiving MIDI data from the LPK, even though the device is recognized.
When I switched to another USB port it worked again, but only one time. Same story for all USB 3 ports. This in itself should indicate something, but I am not sure what!

I tried it with Zynaddsubfx and Musescore - not working there either - perhaps pointing to some problem in ALSA/Jack. But as shown below, indications are that the device is connected, recognized and working. The notes just are not getting through.

In the Jack Patchbay I can clearly see the LPK routed to Renoise MIDI in, and the device shows-up as normal in Renoise Preferences. Everything seems good, except no note data are received, and the MIDI indicator doesn’t blink.

I have searched widely for a fix, but I have been unsuccessful so far. Here are my attempts at diagnostics:

aconnect -i

client 0: 'System' [type=kernel]  
 0 'Timer '  
 1 'Announce '  
client 14: 'Midi Through' [type=kernel]  
 0 'Midi Through Port-0'  
client 24: 'LPK25' [type=kernel]  
 0 'LPK25 MIDI 1   
``` '  

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 10f1:1a2a Importek
Bus 002 Device 004: ID 09e8:0076 AKAI Professional M.I. Corp. LPK25 MIDI Keyboard


[398.314628] [UFW BLOCK] IN=wlan0 OUT= MAC= SRC= DST= LEN=116 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=3838 DPT=3838 LEN=96
[405.609346] usb 2-1.3: new full-speed USB device number 4 using ehci_hcd
[405.702642] usb 2-1.3: New USB device found, idVendor=09e8, idProduct=0076
[405.702649] usb 2-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[405.702653] usb 2-1.3: Product: LPK25
[405.702657] usb 2-1.3: Manufacturer: AKAI professional LLC


sudo rmmod ehci_hcd

...followed by reboot, doesn't solve it.  
- Tried different USB cables.  
- Tested the keyboard on another machine - no problems found.  
Any ideas/Pointers? Would be greatly appreciated.  

Just after I posted I went and installed a midi monitor (gmiidimonitor) to see if I could catch some input. In doing so, the USB connection issue seems to have spontaneously resolved.

LOL - NO idea what’s going on - just glad it’s working.


hm, that’s weird… is this on a laptop?

Glad it is working. I also am using USB MIDI with a linux laptop (Ubuntu 12.10). FYI-My USB midi (Oxygen 25) shows up in Qjackctl under the Alsa tab and the device name also shows up in the Renoise MIDI connetion preferences. I have noticed that USB devices get assigned random device numbers, so sometimes my MIDI keybord is device 0, 1, or 2. That may be the cause of random breaks/fixes.

Oxygen 88 here, and i love this thing :D

Hi - yes, it’s a Toshiba Satellite L series. Intel i5, 4Gb ram, on-board soundcard.

It’s a strange one alright. But it’s working so I won’t tempt fate.