Linux: Videos do not play when Renoise is open

I noticed I can open renoise or watch a video, but not both. video loads but wont play.

Im on Xubuntu 14.04. If I shut down renoise youtube videos and all the tutorials or videos in forum will play normally but if Renoise is open, they wont play, just remain on 0.


Are you using a laptop? May your computer have some power/CPU saving settings that don’t allow too much to go on at the same time perhaps?

I don’t know much about the stuff, but i have noticed on my computer that when my laptop is on power saving there are restrictions to how many videoes that can play at the same time.

if you are using JACK as your audio backend then you will need to install pulseaudio-module-jack. iirc the sink and source will connect automatically when JACK is started.

Mikobuntu, I have no idea how to do all that you just said brother :slight_smile:

I have pulseaudio, I know this

The issue im having is what is discussed in the Renoise FAQ:

"Why Renoise isn’t able to play when other applications are playing (or after other application have used the audio resource)?

As far as we know, in many desktop manager an audio manager is provided (ex. aRts on KDE or ESD in GNOME). The audio manager often locks the audio resource for it’s own use (this may happen while and after an application used it for playback). So, to solve the problem try disabling the audio manager and set all your audio application to use ALSA directly: ALSA is capable of sharing the audio resource out-of-the-box."

So @spktkpt is correct. Just need some steps to follow and do. Not a laptop, a desktop with 16GB of Ram. Top of the line computer desktop.

Hi - Xubuntu 14.04? Same system I’m using.

Now you probably have pulseaudio installed by default. Alsa is a direct hardware interface, but also features soft interfaces. It can share audio for desktop apps, but this task in done by pulse wrapping in between. Now “pro-audio” apps will grab total control of the hardware interface, leaving it blocked for pulse and alsa soft mixing. This is for granting drop-out stability when low delay/latency is used. You don’t want silly clicks and gaps in your audio productions, neither you’ll want a big delay between pressing a key on the keybed and the sound coming on.

I’d recommend using jack for “pro-audio”. You can install qjackctl, it will install all other libs with it. There’s also other more comfortable apps for working with it, like claudia/cadence. Have you already tuned your system in these regards? I.e. rtprio/memlock rights for your user?

I normally have a qjackctl launcher in the taskbar that will fire up jack and turn off processor reclocking. My way is probably a bit silly and complicated, but it works for me. When I want to renoise (or use other audio production apps) I launch jack in beforehand. You’ll probably also need to tune the jack settings a bit. I can help you with that.

Ironically yesterday I was pissed by not being able to i.e. listen into a yt vid in between a session (jack will grab hardware just like renoise), and solution was rather simple: I installed “pulseaudio-module-jack”, restarted pulseaudio (“pulseaudio -k” in terminal). Then when jack is launched again, you’ll see stereo pulse ports in the jack connections. Next step was to go to the volume icon to the settings and configuring the jack sink as “fallback device” (green button) plus routing any currently running (and paused) apps in there to output via the jack sink. Now sound from videos/youtube will have a little gap (and a volume jump) when jack is started or stopped, but can be played together with renoise.