Losing Volume When Rendering

Hi, what should I do to get songs out of Renoise without losing like half of the volume when Rendering ?
Songs are good when made and played with Renoise but when I Render them to Wav’s I lose so much volume that songs are not worthy anymore.
Thank you

Turn the volume up in your mp3 player?

Renoise automatically applies headroom to tracks. It’s set to -6 dB by default but you can change it to 0 dB in the song settings tab if you’re not concerned about clipping.

 This headroom also applies during the live playback so that should not make any difference. 

Maybe the problem is that you use the Renoise with ASIO and listen to render with Winamp or Itunes or something like that which uses windows audio driver. The thing is, ASIO driver bypasses the windows system mixer and is usually much louder because of that.

Also, if your music doesn’t sound very good when it’s quiet then you have to do more work. Playing something louder is a great way to deceive your listening organs thinking it sounds better than it really does. :P

I guess what might work is to put the rendered file into some audio editor, apply slight compression or limiting and normalize the volume to 0 dB… ;) it just takes a minute to do so… I personally render track with more headroom than those default sets, I just put Master volume all way down to avoid the red (and I mean, really avoid, I don’t like those meters too close to the right side :D) and than amplify it to max I can without clipping…

Could you suggest some audio editor I can get for free of charge or with really low and right price. I have FL Studio 9 and there’s some editor and I have used it in the past and what do I remember it worked with sounds made with FL but I haven’t used it with just wav’s I’ve done with Renoise.
I might have use for some stand alone editor so if you happen to know good one could you inform ?

Renoise has a fairly able sample editor built-in…

Otherwise it would help tremendously if you let us know which OS you are using.

Win Xp professional

If you need more flexibility than Renoise’s built-in sample editor, then some popular choices are…

Wavosaur (SoundForge clone):
http://www.wavosaur.com

Audacity:

My favourite for Windows although (unless there has been a fairly recent update) it doesn’t handle large files, I think over about 2GB, so if you want to do long recordings it’s not suitable.

I moved from using these free ones to purchasing the more budget version of Soundforge, called Soundforge Audio Studio (yes the name sounds like it should be an advanced suite but it’s actually the stripped down version.) Still maybe a little much at ~£45??

http://www.sonycreativesoftware.com/audiostudio

G’day all, Having an issue with volume level after render.

For some reason (even after adjusting the headroom option to 0db) my ‘mastering’ renders are all coming out a few db under clip yet you can visually see the compression on the signal.
The ‘mixed’ render (ie the actual project file render) has peaks all over the show up to and including 0db.

To remedy this I loaded the ‘mastered’ render back into the renoise sample veiw and ‘normalised’ to get the peaks upto 0db and re-saved (using right click waveform ‘save sample as…’)
I then loaded this saved file into Audition to export as an .mp3.

Any ideas why the renders seem to be that consistent amount under 0 ?

Cheers
~freely

Turned out to be related to a ‘DC Offset’ issue! Well I think so … always learning! :}

pz

I have this same problem, I have plenty of headroom after recording. I thought headroom in song settings would not affect rendering (a bug?). I can normalize in Audacity later but I’d rather do it directly in Renoise so I know my “limiter and stuff” is working correctly.

But how did you actually fix this?

I leave the ‘track headroom’ setting at default: -6.000 db

I mixed my track to a good level making sure not to clip / leave a fair bit of room like avg. -3db signal peaks

I then rendered this track out without any fx / limiter / maximizer etc on the master

I then create a new song loading in the ‘mix-down’ render into renoise

In ‘sample editor’ I then click ‘remove dc offset’

( making sure to set the bpm and the same amount of patterns or close enough for the track to end including tails etc. )

Using a mastering software or plugin of your choice on mater bus to render the ‘master’ track

even though I have not touched the ‘track headroom’ setting I now notice that the track properly renders with nice peaks just under 0db with 0 clipping.

That’s all I know bro, if anyone can clarify that this is proper practice that’d be cool as!

But good luck mate all the best , hope this helps

~freely

Thanks for the advice! I think your way is right, rendering first to wav before mastering. I’ve been lazy and have tried mastering during the first song render (since cpu is not a problem so far with my plugins).

Just to clarify, you created the master song and just set your first rendered wav as a sample in a track (the only track)? And then used render master track to wav? (not render the whole song function)?

No. I use the normal ‘render’ button ( in the disk browser tab ) and render the whole song length.

So even though the mixed down track is now just a sample that is triggered on a track, the song BPM and the amount of patterns are identical to the original.

eg. The original mixed song in renoise was 125 bpm and 35 patterns in total THEREFORE the ‘mastering’ renoise song is also 125bpm and 35 patterns in total.

and yeah render as usual. ( sorry for the confusion ) I just meant that you would use your preffered mastering plugin ( or chain of dsp effects ) on the master channel before rendering the song.

Cheers

~freely

I would like to see the the render at -6db less feature be made optional on the render dialog window rather than the song settings.