MacBook Pro overheating after upgrading to Big Sur

Well, I’m not sure how this works, but disabling Retina HiDPI support results in 41% on Activity Monitor.
Disabling everything you mentioned gets me to 10%. 6% if I limit FPS to 15, but it’s already silly :slight_smile: Nothing changes the internal CPU load much, it’s 1-2%.

Maybe changing the resolution to lower may also help here.

The 6% is what you’d really want to happen, not the 25%.

Is it workable on a lower resolution with a little higher FPS setting (30)?

(I use a 1280x1024 desktop monitor here)

Also, turn on the ToolTips again perhaps because I never get bored of these.

It’s workable already with a different colour profile, thank you, but seems like it’s something for the developers to look into, since other DAWs are fine on the default settings.

1 Like

Yes…

There are upgrades, much, on Mac…
it is difficult to mention each correct setting for the Mac itself that does not show up in Renoise itself…

It seems like

  • disabling the Retina HiDPI support, choosing the sRGB color profile,
  • setting the menu Edit… Preferences… GUI settings to
    • compatible GFX
    • lowering the FPS to 30 or so
  • perhaps also switch to a lower screen resolution

are steps to take on a Mac to make Renoise run with low CPU usage values.

At least you got it down to 6% after having problems.

Happy Renoising!

1 Like