Mackie Onyx 400f & Renoise

i just wanted to share my fresh experience with Mackie’s new Onyx 400f audio interface, hooked up with Renoise. Everyone considering this unit should be aware…

this is not really a renoise-bug-related psot, i just thought it would fit best in this forum.

well, i have previously tested MOTU’s Traveler with Renoise and other apps on the same machine, and it worked perfectly. 2ms latency and rock solid.

I’ve got a solid windows-based-PC featuring the TI-fw chipset, which as far as i’ve understood is the chipset for best audio machinery.

apart from the GREAT preamps that this Mackie unit delivers,
the rest of the unit was a total nightmare to work with. Together with Renoise it was useless… (40ms (!!) latency with WDM drivers, and it couldn’t even initialize the ASIO drivers). the only samplerate i could use was 44 and 48khz.

It didn’t even work in a satisfying manner with Wavelab or Sonar 4 (using asio). the control-room outputs for the monitors leaked audio, had uneven and noisy gain-stages, and just seemed to be living its own life.

suddenly windows lost the connection with the unit…annoyng.
it also seem to mess with the graphical side of things, as regular wave playback in wavelab and sonar was ‘sticky’.

also, the line-inputs at the rear don’t have enough gain for older synths and outboard gear (90’s stuff i guess). Too bad.

i’m quite sure the unit didn’t match my machine that well, and that other people have had success with it, but such an expensive (and branded) unit shouldn’t be THAT delicate. i guess new drivers will solve some of these problems, but that’s not something i dare relying on. also, i might have gotten a damaged/bad unit, but it still doesn’t make me want to test another one. Has anyone else tried the unit, by the way?

i’m sure glad i could test this thing before purchasing it ;)
I’m going for the Traveler, and probably will start saving money for a standalone preamp instead.

sorry if i’m seem to be sleeptalking here, just a bit tired after hours and hours of testing/failing :D

ok, that’s it for now.

I have the same problem initializing the ASIO drivers.
The Onyx 400F is working fine in Samplitude (both inputs and outputs with 256 sample latency), but when I try it in Renoise I get a “No Asio Driver Error”, and it looks like this

Then, when I go back to Samplitude using the ASIO driver, it says

ASIO Onyx F series loading failed.  
Unknown Error  

So it seems that when trying to use it in conjunction with Renoise, something goes awry with the whole driver.

The same thing seems to happen with Tracktion 2 and Adobe Audition.

(Feel free to move this to bugs, I just thought posting it here would make sense.)

Thanks Bantai.
I actually got it working a few hours ago by selecting ‘do not map through this device’ in the properties of the Onyx and not having it as the preferred sound device like you said. Works great now. :walkman: