macOS Mojave: Internal Error: Failed to connect to the external audio


(esaruoho) #1

Hi guys, what’s going on? I’m running macOS Mojave and pretty much every single (older) module I try to load crashes with Renoise 3, but with Renoise 2.8 I will, while trying to add VST plugin searching into the mix get this error:

Internal Error: Failed to connect to the external audio plugin process (could not establish a connection to the server).


(ffx) #2

By “older module” you mean 32 bit plugins using Renoise bit bridge? Could be that 10.14 prevents any 32 bit execution at all, so the plugin bridge won’t work.

  • Do 32 bit plugins still work in other DAWs?

  • Do ist work if you only load 64 bit plugins?

  • What happens if you disable sandboxing in the settings (and then restart renoise)?


(esaruoho) #3

By “older module” you mean 32 bit plugins using Renoise bit bridge? Could be that 10.14 prevents any 32 bit execution at all, so the plugin bridge won’t work.

  • Do 32 bit plugins still work in other DAWs?

  • Do ist work if you only load 64 bit plugins?

  • What happens if you disable sandboxing in the settings (and then restart renoise)?

With v3:

32bit plugins, when loaded into 64bit renoise, look like this:

8098 Screenshot 2018-06-20 at 23.48.20.png

When enabling “run all sandboxed”, some 32bit plugins load, but for instance TAL-Dub I & II do not show anything, even sandboxed.

however, i cannot be running plugins sandboxed, as i need to have keyboard input into pattern editor at all times.

With v2.8:

8099 Screenshot 2018-06-20 at 23.51.24.png

this is what ValhallaDSP Freq said, before Renoise 2.8 crashed.

not sure which log to look at?

okay, plugin log says this:

AU: Trying to open plugin:'Valhalla DSP, LLC: ValhallaFreqEchoMkI' (aufx:FqM1:oDin)...
AU: Setup I/O...
AU: Plugin suggests routing: 1 inputs, 2 outputs
AU: Plugin accepted routing: 2 inputs, 2 outputs
AU: Inputs: 2 (max:1) Outputs: 2 (max:2) in 1 busses
AU: Setup Rate/Blocksize...
AU: Initializing...
AU: Setup Parameters and Presets...
AU: Start running...
AU: Instantiate OK

AU: Opening editor window for plugin 'Valhalla DSP, LLC: ValhallaFreqEchoMkI'...
AU: Found a custom cocoa editor view component ('ValhallaFreqEchoMkI_AU')...
AU: Failed to create a window from the nib file!

Error Message: Failed to create the plugin GUI. See the log for details.

hope this helps.


(ffx) #4

Check if those Tal vsts behave the same in another daw, E.g. bitwig, so you now then know that you should blame tal. Happens to me, too, since 10.11. if so, we could both bomb tal support then, if they can fix this (also noisemaker :frowning: )


(ffx) #5

OMG TAL finally updated TAL Noisemaker:https://tal-software.com/products/tal-noisemaker

Or maybe I missed it? It works great again in macOS 10.13, also Renoise, and is 64 bit now!!


(ffx) #6

Would be nice if the 32-bit-bridge still was working on macOS 10.14 (because AFAIK Apple drops 32 bit support in total). Such a pity that Taktik never drops in and shares some of his views and knowledge… :unsure: