MIDI Clock: Song Position Pointers and Speed Automation

Hi,

Is this a bug?

Renoise does not seem to receive song position pointers correctly when using MIDI sync from other hosts.

If you are at the middle of composing a song, and would like to edit a certain part of the song, Renoise will start it’s playback from the beginning while the other software loops the part that was meant to be edited.

Hope this could be fixed.

Peace,

[quote="#<0x0000562855bf4590>"]
Hi,



Is this a bug?



Renoise does not seem to receive song position pointers correctly when using MIDI sync from other hosts.



If you are at the middle of composing a song, and would like to edit a certain part of the song, Renoise will start it’s playback from the beginning while the other software loops the part that was meant to be edited.



Hope this could be fixed.



Peace,
[/quote]

I can easily attach Renoise to Reaper and then play from any position in Reaper, Renoise goes along just fine. (there may be a delay before the actual synchronisation is interpreted correctly, but it does work)



You turned on the midi-clock sync in Renoise?





What other hosts do you use?



There is currently only one host that lacks to send timestamps which is Logic (and is a bug in Logic), but this would cause other problems as well…</0x0000562855bf4590>

Hi,

thanks for your reply.

I’m using Cubase SX 3.

Yes the Midi clock sync is turned on and renoise syncs otherwise perfectly, but if you loop a section inside a song in cubase then the positioning gets skewed.

I am not exactly sure how it is in Cubase SX3, but most MIDI clock hosts have some options how and when they send SPPs and when not. Make sure that you’ve enabled sending SPPs when looping or while the master is playing (so that it not only sends SPPs when starting to play).

Maybe someone else with Cubase SX 3 or the people in the Cubase forums can help you here… In general we do support SPPs, so I dont see why this shouldnt work with Cubase as well.

hmm,

(thnx. I tried all the possible settings in the cubase’s sync setup)

it does beging the playback on certain places in the middle of the renoise song, but the placement is not correct.

It seems to be about 1 bar off in renoise when a certain place is looped in cubase. other times it is half a bar (using barlenghts of 80, and speed 1,5 [1 and 2 on every other line])

Sometimes it is half a song off and sometimes other.

This can be solved though if someone else is experiencing similar problems:

do not send SPP’s from the external seQ if it is buggy and loop the section inside renoise manually.

Thanks for all the responses.

and sadly the workaround does not function on all occasions.

There seems to be something that makes Renoise decide to begin the song randomly at the loop point and the beginning of the song, when a start message is sent from the MASTER sequencer.

This happens even without the SPP’s being sent and I bet this has something to do with the bug with the SPP’s receiving the songposition randomly…

not sure not a programmer, but seems like the playback position is somehow changing randomly.

I think whatever causes this, it would be best if renoise could start the playback from the beginning of the loop if midi start message is received. I think there is no scenario where start from beginning would be needed if there is a section looped in renoise when using 2 sequencers simultaneously.

hmm… back to twiddling. ->

Hi

Found out that this is a bug and I think you can confirm this.

The reason you vV got the syncing working and I did not is that I’m using the speed 01/02 which is a F101 and F202 on every other line.

The SPP’s are not received correctly if the speed 1,5 is being used. And the song jumps randomly from startpoint to another.

I bet you were using speed 6?

[quote="#<0x0000562853009020>, post:7, topic:21467"]
Hi

Found out that this is a bug and I think you can confirm this.



The reason you vV got the syncing working and I did not is that I’m using the speed 01/02 which is a F101 and F202 on every other line.
[/quote]

If you alternate in speeds there is actually not much that can be done to prevent that.

There is an amount of msecs delay between master and slave when using MIDI and when you switch speeds master and slave need to be resynchronized with timestamp corrections to get this fixed.

If two or more changes occure inside the delay-time, neither master nor slave knows how to treat the timestamp correction.

The better the MIDI timing on the host platform, the better the synchronisation.

Windows sucks big donkey rectum when it regards MIDI timing and specially when changing bpm or speed quickly this is very noticable. Best results can be achieved by using the WDM driver and low ASIO latency buffer setting and if you have a multicore CPU, deselect one or more cores in the audio preferences of Renoise to give MIDI in windows a higher priority.



You may get better results by using the groove option in the “Song Settings” area if that effect is what you desire with the alternating speeds. In that case, BPM and speed remain at the same level. Alternating speeds is an oldskool trick but does not always pay off.



</0x0000562853009020>

Alternated/automated speeds (when they change the signature) are simply not supported when running as slave. Imagine the chaos they introduce…

yeah, this is totally understandable.

would it somehow be possible to get support for this(longshot)

If you want to understand the load of your appeal seen in the developer’s context of opportunities:
Maybe for Mac and Linux there might be reasonable chances such support works out, for Windows likely not at all.
It might work better in Vista but Windows remains a load of crap when it comes to MIDI timing accuracy.
In theory everything is possible but in practice, not all components are adaptable to make the dream come true.
I bet ReWire will be the better alternative, but then again delays mark the true limits.

Such things require realtime priority which more or less also requires a dedicated workstation solely operating the two hosts only.