Midi Mapping Roland Pc-180

Hi!

I have tried to find out how to map the pitch bend wheel
on my midi keyboard, but Renoise 2.7 does not recognize when
I move the pitch bender wheel in the midi mapping.

The pitch bender does change values in a pattern column when
the midi mapper is not open. Also the midi mapper can correctly
map the “data entry” slider and the modulation,…

I would really like to use the pitch bender though :slight_smile:

Can anyone give a hint?

A bit tricky workaround though;

  • Install latest Duplex beta version.
  • Select [Tools] >> [~Duplex] >> [~MIDI-Keyboard] >> [~MIDI-Keyboard Keyboard] config.
    Then you can see the virtual keyboard of Duplex,
  • Open the [Settings] panel on the virtual key
  • Set MIDI-in port on there and set [Keyboard] >> [Pitch Bend] option on there too (select “Route to CC#??”, for exchanging the pitch signal to CC).

Now you can map the pitch bender to anywhere in Renoise by the MIDI-mapper.
If you want to avoid being inputted pitch bend commands on the Pattern Editor, uncheck the “Pitchbend & Controllers” option on the Renoise’s Preferences panel. (Since pitch signals are inputted via Duplex port, it is unnecessary any longer)

#############
But currently, there seems to be a tiny issue about mapping the pitch bender. See this topic too:

Hi,

Thanks for your reply!

I tried the latest Duplex beta as you recommend, but there is
no midi keyboard menu entry, maybe I am misunderstanding you?

I tried playing a bit around with duplex to see if I could find
a variation of what you describe, but no luck.

I think I can do without the pitch bender for now I guess, but
maybe this will become fixed at a later point…

Ahh, now I read your first post again and I notice you are using Renoise 2.7 still.
The latest Duplex 0.98b15 needs Renoise 2.8, so the workaround doesn’t fit in your case unfortunately.

Aren’t you going to use 2.8?
(If you aren’t a register user, the 2.8 demo version will come in the near future, I think.)

Hehe, of course I will use 2.8 :slight_smile:

I was just too busy with composing/sorting samples, etc. :slight_smile:

I’ll give it a spin, thanks!

Hmm, not really sure I am doing it right…

In renoise 2.8 (With a TON of nice features, joy!) the pitch bend creates M1 … Values in the
panning column which I think is a correct identification of my pitch bender. It has no effect
however and I am still unable to use the pitch bend.

I tried doing what you suggest, mapping to C0, but it did not work despite my efforts. Maybe I am
missing something.

BTW I really like that I can collapse patterns in 2.8 and so much other nice stuff, very nice!

I tried doing what you suggest, mapping to C0, but it did not work despite my efforts. Maybe I am
missing something.

In this picture, I’ve mapped the pitch bend using standard MIDI mapping (CTRL+M) after having selected “Route to CC#”.
You can route the pitch bend to any parameter, I just mapped it to the MIDI Control device as an example.

duplex_keyboard_pitch_mapping.png?raw=1

Hi,

Thanks for the example!

That might have cleared things up a bit for me, but now I get:

  
Renoise LOG> Exception: Socket send failed (111: 'Connection refused')  
Renoise LOG> Exception: Socket send failed (111: 'Connection refused')  
Renoise LOG> Exception: Socket send failed (111: 'Connection refused')  
Renoise LOG> Exception: Socket send failed (111: 'Connection refused')  
...  
  

In the console, when I move the Duplex MIDI Keyboard pitch bend slider
after having pressed CTRL-M to activate the midi mapping learning.

This happens with all the CC# I have tried to route to also if I click
one of the keys on the Duplex MIDI Keyboard.

This must be a permission issue, maybe I have a problem somewhere in
my setup?

I think it’s because the Renoise OSC server isn’t started?
Since Keyboard’s functionality is based around this server, you need to enable it first (Renoise preferences > OSC)

Check also this topic which explain the Keyboard application in detail:

Yay, I think that was it!

It works with UDP not with TCP,… and now I have my pitch
bender mapped, cool!

Thanks a lot, and thanks for the good work!

Hmm, one funny thing:

I am creating some instruments with ReSynth and if I enable the OSC
server some of the layers of the instrument that I have tuned an octave
up or down are played at a different octave making my synths sound really weird.

Maybe this is a ReSynth issue, but though I would report it.