midi mapping -- 'smart' sequence repeat, BPM

I’m trying to map stuff to an LPD8 for live use, and having some trouble. I’m sure someone can help…

  1. I want to move back and forwards in the pattern matrix, and ‘select next sequence’ and ‘select previous sequence’ map to the controller just fine. The behaviour I want, though, is for whichever pattern I’ve skipped to to automatically be set to repeat… until I tell it to jump to the next/previous one. How can I do this?

  2. I want to map the global BMP to a knob, but it only allows values between 60 and 187, and not as a knob – only as a button. I’m sure this is a setting I have wrong rather than an actual limitation of the software.

Any advice is welcome…

If you already have more than a sequence, you can midi map it to a note on a keyboard (I am setting mine up in C minus 2 and on).

Or you have a button to trigger that sequence. You say you want to go back and forth, that is right what you 've done, selecting next and previous sequence to be mapped onto buttons.

I have succesfully set up a fader/ slider to change/set the bpm (using the Maschine as a controller and/or the MIDI Designer on the iPad).

Also, Set a button to Loop the pattern, and more buttons for the Block loop operations, if that’s what you intend to do.

I want to move back and forwards in the pattern matrix, and ‘select next sequence’ and ‘select previous sequence’ map to the controller just fine. The behaviour I want, though, is for whichever pattern I’ve skipped to to automatically be set to repeat… until I tell it to jump to the next/previous one. How can I do this?

Should be possible simply by enabling transportpattern loop (also available as Loop Pattern in midi mappings) - the playing pattern should now loop, no matter which one it is.

I guess you have looped one or more patterns using the pattern sequence? Because, they are fixed, will not follow the active playing pattern.

I want to map the global BMP to a knob, but it only allows values between 60 and 187, and not as a knob – only as a button. I’m sure this is a setting I have wrong rather than an actual limitation of the software.

Hm, sounds like Renoise somehow misinterpreted the controller message. Try mapping it once more?

As for the range - 7 bit messages only allow 128 unique values, so a range of some kind has to be agreed on.

And 60-187 was simply chosen as a default and musically useful range.

However you can change those values to something else by overriding the default midi mappings.

  1. Open the Renoise program folder, locate the subfolder /resources/scripts

  2. Take a copy of the file GlobalMidiActions.lua <-- this file specifies the default MIDI mappings

  3. Open the Renoise application folder (e.g."%appdata%/Renoise/3.1.0" on my windows PC)

  4. Navigate into the scripts subfolder and paste the file here <-- this will force Renoise to load this as an alternative file on startup

  5. Open the file in a text editor and find the following

add_action("Transport:Song:BPM [Set]",
function(message)
  song().transport.bpm = message_value_with_offset(
    message, song().transport.bpm, 60, 32, 999) -- 60 is offset, the value you want to change
end)

Thanks Danoise!

I made this comment quite a while ago, the first problem I mentioned was solved by that piece of code you gave me that enables ‘play next’ without skipping immediately. (That works really well.)

The second, I shall now test out…

I really do appreciate how responsive you are. It adds a lot of value to the software.