Midi Out Of Sync While Playing Song


I’m trying to use Renoise together with Reason (4). Where I want to use Renoise as the master of Reason.
As the virtual MIDI cable I’m using LoopBE1.

So I’ve created an instrument and all seems fine when I use the computer’s keyboard to play some notes. Renoise redirects that instrument through to Reason and the note gets played instantly. No noticeable delays as far as I can hear.

For testing sake, I’ve created a pattern where on track 1 and 2 I placed some samples and on track 3 I placed some MIDI notes.
Now when playing the song, the MIDI notes are very delayed. I tried to adjust it by changing the “MIDI clock master” configuration (altering the offset) and set Reason to listen to the MIDI clock of Renoise, but that doesn’t seem to have any effect at all.

But what’s really weird, is when I mute track 3 (the one with MIDI notes) and play along with the song by hand, there are no noticeable delays at all. The delay only occurs while playing the song from the track.

What did help some (not enough though) was putting the instrument delay to -50. But I need -85 :)
Is there a general configuration setting of some sort, where I can adjust the delay of all MIDI signals?

Any help appreciated…


Renoise currently assumes that all MIDI instruments are “real” MIDI instruments (external gear), so all playback messages to the Synth are automatically delayed by the audio latency.

We already have added an option to get softsynths on Linux via Jack working - which suffered exactly the same problem., so in the next Renoise update you will be able to disable that “extra” delay.

For now the only workaround is to keep the Audio Latency as small as possible, then use the insturments delay option to get it in sync (as you already tried).

Thanks for the answer…

Do you know how many millisecs the current delay is? Is it more than 50 ms (as in the instrument options) or should I get a new soundcard? :)