Midi Problems

Hmm… I need a bit of help here.

I’ve just got hold of an Axis-49 MIDI controller and can’t seem to get Renoise to recognise it.
Infact renoise doesn’t recognise the MIDI interface of my soundcard either but has previously (Echo Audiofire 2).
I’m running Vista Home Premium SP2 (32 bit).

I’ve just tried both of these interfaces in Ableton Live 7 and they work fine.
Adobe Audition also lists both interfaces in its preferences.

I’ve tried starting Renoise without the Soundcard, without the onboard soundcard, with all soundcards disabled, rebooted several times etc.
Just newly installed Vista SP2 as a long shot but it’s made no difference.

Nothing on my system has changed since the last time I used MIDI apart from plugging in the Axis-49 controller and letting windows successfully recognise it as a generic audio device.
Device manager seems to think the drivers are up to date and the device is working properly.

The only clue I have is Renoise’s error dialogue on startup: Failed to open the MME MIDI Device ‘Unknown device’!

In Renoise’s MIDI options ‘Unknown Device’ appears once (there should be 2 devices present), on selecting it I get the same error message.

I’m officially stumped… any ideas? What is MME?

I think MME is some kind of emulation layer. “Midi Machine Emulation” maybe?

Sorry, that doesn’t do anything to solve your problem.

Maybe you need to install a specific drivers?

MME is usually indeed the usual emulation device (and far slower Midi driver) for your soundcard that is present.
I think there is something different with way the WDM driver presents itself towards the system that Renoise does not recognise this. Not something to look in the Axiom corner, but your Echo soundcard corner.

You also mention to work with Vista, now because your midi controller works in Live and Logic, this means that either these hosts use their own drivers and something is wrong with the Vista driver or something in the Renoise configuration went wrong.
Is there also a difference for instance if you start Renoise 2.1 or 2.5?
And what if you would trash / rename the Renoise 2.1.0 and 2.5.0 folders in the […]\application data\Renoise user space area and then restart Renoise 2.5 with a clean slate?

datassette: Under which name do the MIDI ports show up in the other applications. Are both named “Unknown device”?

@taktik They are listed as:
‘AXIS-49 2A’, and ‘AudioFire2 MIDI’.

I installed MIDI-Ox and MIDI-Yoke to see what was going on. MIDI-Ox also listed both interfaces, and pressing notes on the Axis-49 was sucessfully logging note on and note off events. So then I thought I’d try using Yoke to route the data into Renoise.
So I start up Renoise and now both devices are listed!
And after quitting MIDI-Ox they can be selected in Renoise and both work!

It seems that Renoise will only ‘see’ the MIDI devices if MIDI-Ox is running when it starts up.

Well at least it works now! :badteeth:
Something weird is going on here though, any ideas?

@Vv I didn’t think to try trashing the preferences, just tried it and Renoise gave the same error message after the Ennumerating MIDI devices bit.