Midi Toggle On/of On Max Value

Ok Stay with me :)

I have an external controller (BOSS GT6) with a button that sends a max value when pressed and a min value to release.
I want to use it to toggle a slider in Renoise to a max and min value.
My problem is I have to hold the button to stay in the max value. when I release it, it will go back to the min value.
I want it to toggle the state of the slider inside Renoise with a press.

Can it be done, and how?


I don’t have my MIDI controller here at the moment, but when you go to MIDI map the slider take a look at the Map Mode setting. You have various different types in there, including a toggle behaviour.

Tnx dblue, but those options only seem available when mapping notes, I’m only left with absolute 7 bit and the relative variations.

Ah, hmm. Sorry, I’m so used to my Novation controller where I can set the buttons to ‘Drum Note’ mode, so I was just thinking back to how they work.

Maybe it’s possible to configure your BOSS GT6 to do the same, ie. broadcast a MIDI note from the button?

Thanks dblue, but I read the GT6 manual very carefully and tried every possible setting. It would be a weird option to have on a guitar FX board imho, but I would welcome it now :)

Well I solved it somewhat. The simple idea was to mute/unmute the guitar with a press on the button of the GT6.
I now assigned it to the tuner’s mute button inside Guitar Rig 5 VST.

The only thing now is I rather wanted the signal being cut off in front of Guitar rig to save me some CPU power (while it goes in auto suspend when there is no input)

If someone has a good idea to achieve this, I still like to know.

Here’s a quick DSP chain that might help:
3136 dblue-mute-toggle-switch.xrns

You can simply trigger LFO 1’s Reset function to toggle the Gainer between -INF dB and 0 dB.

Perhaps you could insert this before Guitar Rig, then map your MIDI button to the LFO Reset? Hopefully this will circumvent the lack of a true toggle behaviour.

dblue, genius! a little weird but very inventive way and it works!
Many, many thanks!

dblue, a very weird thing happens, I paste your chain into my song where it doesn’t react the same way always.
I now got a song where it click unmutes, click stay unmute, click mute, click unmute …enz.
do I have to change speed settings from the lfo’s?

I now tried moot and, again, thought I was saved.
It does what I want but it’s eating very much CPU. So much it’s not usable.

There has to be a way to solve this simple little thing…

I’m using Plogue Bidule for all these kinda MIDI manipulation. Maybe a bit over the top for only one button, but if you like to do more advance stuff it might be worth checking out. I run BiduleVST on the Master and send MIDI signals through MidiYoke. Unfortunately the plug-in version is only available for registered users. And also, the current demo expires on March 22, perhaps a bit soon to try it out properly… there’s usually a small gap before the next demo version comes out. :confused:


I did test the DSP chain with different Lines Per Beat values, different BPMs, etc., but I’ve now noticed that it only works correctly if you use an even-numbered Ticks Per Line value such as 6, 8, 10, 12, etc.

If you use an odd-numbered TPL value, then the LFO will unfortunately drift around a bit. I simply didn’t notice this before because I usually stick to the default of 12 TPL.

Can you check if you’re using an odd-numbered TPL value in your song, and if changing to an even-numbered value fixes it?

dblue, once again, you are the man :) I have some tracks that origin from my Amiga digibooster times.
I never really mess with the TPL but now I can see that somehow, during the .DBM to .RNS conversion via .XM back in the days,
some weird codes are introduced that affect the TPL. I only noticed some weird things with pitch bends which I can correct now :)

So I corrected this stuff in all my songs now and your solution now really works!
and while digging into this, we even tackled a problem that was present for years it seems <_<

Again big thank you!