Minor Linux Terminal Issue, New User Issue

So, I was playing around with trying to install VSTs on my Ubuntu (9.10) netbook for use with Renoise (2.5, RC1), and followed the directions I found online:

$ echo VST_PATH=/path/to/my/vst:$VST_PATH >> ~/.bash_profile
$ echo export VST_PATH >> ~/.bash_profile

I thought I set it up to check a folder I put on my SD card, but that didn’t really work. I eventually managed to create a VST folder in usr/local/bin (moving all the VSTs to that folder) and that seems to have done the trick, because the VSTs I installed now show up and work in Renoise.

Here’s the minor issue. Whenever I start Terminal it now says “VST_PATH: command not found” due to the poking around I tried earlier. So, how do I undo the blind tinkering I tried and failed at? Everything seems to work just fine, nothing is broken, but it annoys me because it’s a flashing red flag for my Linux ignorance whenever I open up Terminal. :)

Any Linux wizards care to help me undo my stupidity? I’ve done a little poking around, but aren’t skilled enough to figure out how to fix what I did.


Remove the VST_PATH lines from .bash_profile or remove the .bash_profile altogether. It should be automatically regenerated.

$ gedit ~/.bash_profile

Only reasonable explanation for your error is that you have space character between the VST_PATH and = (equal sign).

VST_PATH=/home/suva/vst # works  
VST_PATH = /home/suva/vst # VST_PATH command not found  

Default locations for VST’s was /usr/lib/vst, /usr/local/lib/vst and ~/.vst, the last one is in your home directory, and it’s smartest to use that one.

Also note that changes you make to .bash_profile will only affect renoise when you run it from the terminal. It has no effect on renoise instances you start from icon on the desktop for example.

Second this. No need to fumble around with the paths. Instead simply use the defaults.

Thanks for such a prompt response, guys. I really appreciate it, especially since this really isn’t a Renoise issue any longer.

I actually tried Suva’s suggestion of using gedit to modify the paths, before I posted here, and the .bash_profile was completely empty. It still is. Removing it didn’t clear things up either, so I think Suva’s suggestion that I goofed up the syntex when I entered the command might be right. I’m at an even larger loss on how to fix it now.

TakTik, yes… you’re completely correct. Messing with the paths isn’t worth it. I seem to have learned that the hard way. :)