modulation envelope ..collapse without maximizing envelope

IN previous betas , while envelope was maximized ( not full screen ) .
When we clicked on the small white modulation envelope arrow, this collapsed the underlying mod.envelope …which resulted in faster
editing because the mod.envelope graphics were not processed ,while still being able to work in a maximized env.window( not full screen )
Now , when clicking the collapse button ,it automatically maximizes the envelope to full screen ,collapsing is not maximizing !
Altough the modulation envelope is behaving better then the first beta , it still consumes resources when envelope editing .
In beta 6 we had the option to collapse the mod.envelope while still doing envelope editing .
Now collapsing means full going screen .
This is no longer the case , can we please have this option back ?
Or please an option to totally disable the gui mod.envelope …

some pictures

https://app.box.com/s/hopnwsnkwkxvelqqxl6g
https://app.box.com/s/tel7wa8wj3k28kiyubo2
https://app.box.com/s/bjlc73hn7t4m8etxhk97