Mute And Solo - Implement Differently?

What is required to change the Mute and Solo controls on the mixer, so that it doesn’t cut the note/sample, but instead just affects the mixing path?

If I load up 8 tracks of full length samples, and line them up on row 00 of a pattern, and then set them to play, after using the Mute or Solo functions on the mixer, I can’t un-Mute or un-Solo the other channels. They only start playing when they are retriggered next time in a pattern. The samples get cut when the Mute is applied, rather than the mixer being told not to include them in the mix. It means when you unset the channels from Mute, there is no sample playing to be unmuted!

I think the sample shouldn’t be told to stop playing by a function of the mixer, as they are separate devices. It would make Renoise that much more a useful tool if the mixer was implemented this way (a lightweight VST sequencer, with a :ph34r: mixer)

I think this would be an improvement - you could still cut the note (if you want to) by enabling record and pressing CAPS in the track you want to cut.

I can understand why you may have implemented it like that - a you can gain performance by not considering the sample at all if it has been muted… if you only use short samples, this doesn’t have a very observable effect. But I tried to use Renoise experimentally to mix down some tracks ( :yeah: we do like Renoise :w00t: ), and noticed this “feature”…

Thanks very much for an awesome piece of work I must say!

Hold ctrl or shift when pressing solo/mute in the mixer/scopes.
Or simply change the default behavior in the Renoise Preferences.


oh wow! thanks


shoulda spent more time searching, and less time asking :rolleyes: