Mute doesn't mute audio for VSTs

There’s an odd behavior with the mutes. I’m running an ACE demo with the periodic crackling noise. When I explicitly set the routing for a plugin to a particular channel and then mute it, there’s somewhat odd behavior I noticed:

  1. When I play a note on the keyboard, I still hear it.
  2. I still hear the demo-limitation crackling noise

This leads me to suspect the implementation of mute with respect to routed VSTs is that note on events get ignored. But what if I intend for the channel audio to really be muted? I’m aware that one possible workaround is to auto-suspend, which puts the plugins sufficiently to sleep that they don’t crackle. Is there a non-workaround approach that actually mutes the channel audio?

Maybe somehow simillar? There i couldnt change prevolume of vsti…

Do you have this setting properly?

  • Mute mode (left click): - Off: After a track is muted, any existing sounds may carry on until finished, but notes and other events will not be triggered (Soft Mute). - Mute: The track is played back completely and can be immediately silenced/unmuted without affecting how any of the sounds are executed (Mixer Mute).
    else just Ctrl+click will mute the channel as well instead of offing it.