Mutiinspector VST Gui Not Responding on OSX 10.3.9

im running OS X 10.3.9, Renoise 1.9.1, and the new version of MultiInspector (the version you pay for).

when i load the vst the meters work but none of the buttons respond when i press them.

i contacted VertexDSP but i thought i would let you guys know also.

please let me know if you need any additional information.

This seems to be a problem on OSX 10.3.9 only, on Leopard the buttons work just fine.

Let me test this later on an old PPC with 10.3.9. I will then contact the VertexDSP and ask them for help. Maybe this is a know problem?

cool cool thanks.

o…i don’t know if this should be in its on thread or not but…

renoise crashed when trying to close the app. with it initialized and i get this message in my console

Link (dyld) error:

dyld: /Applications/ NSLookupSymbolInImage() dynamic library: /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation does not define symbol: _CFStringGetFileSystemRepresentation

Just tested this on 10.3.9 and there it also works fine. Which buttons do you mean? Does this always happen? Are you running the latest version of the plugs? I’ve tested this with the demos (2.2.0).

The only strange thing I’ve seen is that after choosing a new track color, Renoise might not respond anymore because the dialog still seems to be open.

it happens with any button on the gui 1/3 or fft , knobs, mutes, solos, choosing new track colors ect.

i am using the latest version of the vst 2.2.0 and the free version worked fine for me also so that why i figured id buy it. i will have to try the demo to see if that works.

ok this is a little unsettling.

the demo gui is not responding for me!

and when i try to remove the plug renoise crashes.

i have not yet received an email back from vertexdsp yet, but hopefully i will.


ok so i tried a new build of renoise and while scanning the vsts it crashed while scanning multi inspector 2 times

this is the first error message from my console:

Command: Renoise
Path: /Applications/
Version: 1.9.1 (1.9.1)
PID: 441
Thread: Unknown

Link (dyld) error:

dyld: /Applications/ NSLookupSymbolInImage() dynamic library: /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/CoreGraphics does not define symbol: _CGContextStrokeLineSegments

this is the second when i restarted to finish scanning:

Command: Renoise
Path: /Applications/
Version: 1.9.1 (1.9.1)
PID: 447
Thread: Unknown

Link (dyld) error:

dyld: /Applications/ NSLookupSymbolInImage() dynamic library: /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation does not define symbol: _CFStringGetFileSystemRepresentation

even though they failed they still show up in the dsp vst search box

there are also two instances showing


sorry for being a pain in the ass. :wacko:

Do you already tried to completely remove all MultiInspector VSTs (try finding all of them and trash them), then reinstalling them?

This CGContextStrokeLineSegments crashes look like its not fully compatible to OSX10.3.9 (they use functionality which is not available in OSX10.3.9).
Updating Quicktime to the latest version might solve this. Thats maybe also why it works here and why the buttons do not respond for you.

well i have been trying a multitude of thing with the help of VertexDSP support.

I have to ask what version of quicktime are you using because i have installed 7.4.1 (v14) and i thought that was the latest.

the the gui works now but after every mouse action i have to double click the enable keyboard box at the bottom of the vst to be able to make another adjustment (which i could get use to). the only thing that kills me is the crash when trying to remove the first instance of MI.

i even erased my hard drive and reinstalled everything, (i dont mind though, i had to anyway just to relieve clutter), and made all the updates and the problem still persists.

but hopefully they can fix this and if not i may just need to upgrade my OS.

ok this is all sorted out now. thank you for all your help. now ill stop bugging you guys with my problems. lol :D

What was the problem? Or have you updated your Mac OS version?