My keyboard suddenly acts as a qwerty in renoise.

Hello guys!

My keyboard acts as a qwerty keyboard in Renoise only. It’s very strange.

I found no options within the software.

Am I missing something?

Hello!

Perhaps the beginning of an answer in this post:

https://superuser.com/questions/466180/set-windows-8-to-per-application-input-language-mode

Hope it can help you.

Bye.

My keyboard acts as a qwerty keyboard in Renoise only. It’s very strange.

What are you using, qwertz?

I’ve noticed that certain “operating system level shortcuts”, such as undo and redo, are automatically picked up by Renoise and translated into the correct layout.

Most of the time, this is done without you noticing and works flawlessly. However_…_ since I’m often switching between multiple different input languages, I have found that Renoise can sometimes save these special keys in preferences and not pick them up as the layout changes.

Since I haven’t been able to recreate the problem, and only experience it occasionally, I haven’t really been able to file a bug report. But I usually solve it by taking a few seconds to reassign the shortcuts. Most often, this involves assigning CTRL+Y --> CTRL+Z. For now, I would advice you to try the same - find the shortcuts that are not working (Preferences > Keys) and correct them.

On a sidenote: how people in Germany can live with the unergonomic “CTRL+Y” for undo, I will probably never really understand :wacko:

Wow, ok. Thank you very much . I did check yesterday but there’s so much shortcuts I got lost. Yeah, it implies to re assign Q for notes off, and ctrl+z obviously.

I will check this.

Thanks again folks!