New Backstage Testing

Hey Guys,

we have been working on a new Backstage in the past weeks. Before we flip the switch and go live with the new code, we need to do some real world testing. So if you have a few moments to spare, please help us by logging in into the new backstage, downloading your copy of Renoise and letting us know if you encountered some major issues.

the new Backstage is located at an intermediate URL: http://backstage.renoise.com:8081/

A couple of things to mention:

  • The new Backstage uses an own version of the database. All data has been migrated about two weeks ago, so If you purchased Renoise after that your account wont’t be available in the new Backstage yet. - Login scheme has changed, instead of " " it is your primary email address now. - Downloads take a couple of seconds (Windows) up to 20-30 seconds (Mac/Linux) to prepare. Just be patient, we need to add some notes on the download page (perhaps a progress-bar or something) to make this clearer. - The login-form can be a bit bitchy at the moment when used with password managers. So if the login-button is not enabled, re-enter your credentials manually (or change at least one char per field). - We can only fix bugs which we can reproduce. So while we would love to hear all of your problems, it would be really great if you could provide as many details as necessary to reproduce a problem. I know this is not always possible. - Always include your browser type, browser version and operating system information in a issue report.

Known / confirmed Issues

  • Legacy Passwords (migrated from the Old-Backstage) will only work once. You will need to change your Password once you logged in, or perform a Password-Recovery. - Proposed download-arch seems to be a bit wonky for at least Windows downloads - OS X 32 Bit downloads are borken.

Cheers and many thanks in advance!
Paul.

Testing this now !!


So far so good, no bugs and worked very well. And speed is more than perfect !

Had to reset my password in order to get it work. Besides that, haven’t got any problems, really like new design.

as in state not saved after hitting the “save” button below?

Works fine here. Nice design!

Tried to download the 32bit version on OSx and it took me to a blank page with a big long URL but no download happened.

OS is Mavericks
Browser is Safari Version 7.0.1 (9537.73.11)

Confirmed. Fix on the way. Thanks!

Login failed. (Firefox 26.0, Win7 Ultimate x64)

My password contains special characters like “*” which might be a problem as well, but it works with the old backstage.

  • EDIT *

My fault, I tried to log in with my other e-mail address, now it works. Sorry!

Ok, I tried it on Chrome and login failed, then I went back to Safari and then login also failed.
I then reset the password and tried to download again in Safari and this time it worked ok.

Works fine here but I find it weird that it shows 64 bit beta and 32 bit 2.8 as the defaults before expanding.

Looks fine to me, (Firefox 26, Windows 7)

Login worked once, but now doesn’t anymore. Google Chrome. Also, when logged in, the design was the same, only the content changed.

This happened to me too

Any hints on how to reproduce it? What do you mean by “the design was the same”.

Sounds vaguely like caching issues with multiple tabs mixed in.

I have same issue as fladd. Signed in to the new backstage with my old password in chrome, everything worked fine.

I then left the page, tried to log in a little while later, and it says login failed.

I’ve since cleared my cache and tried again. Still cannot login in chrome. Tried in internet explorer, login failed there too.

Confirmed here as well.
I did changed my email though as the email i had my account registered no longer works.
But i can’t login neither with my old neither with my new email.

Confirmed here as well, firefox linux 32bit. Logged in once, can’t login again.

Btw, it only shows the version for the OS and bit-addressing i’m using at the moment. What if i want to download another one for a different computer that can’t access the web, or different OS/bit-addressing on the same computer?

/* edit */ duhh

Seems to work fine here.