New Tool (3.0): Akaizer

fladd: What would be very interesting is if you find the ‘main.lua’ file that you are running from your version of this tool and attach it to a post so that Ben B can verify first of all if you are both ‘on the same page’ so to speak :slight_smile:

The tool works now. I did not realize that I had to download a patched main.lua. This is not very obvious from neither the tool page, nor the first post here.

I suggest to upload an updated version of the tool to the tool page.

The tool works now. I did not realize that I had to download a patched main.lua. This is not very obvious from neither the tool page, nor the first post here.

I suggest to upload an updated version of the tool to the tool page.

Good to hear you got it working, fladd. I agree about the confusion of which version is the most recent. I assumed you was you using my latest patched version (v1.03) but obviously the main download links point to the older broken version.

I would be happy to take control of this tool on here as it seems the OP (lwpss) is no longer interested in maintaining it (last active 20 Dec 2016). Is there an admin I can contact about this?

Dude, Ben B? you are the original creator of Akaizer? TALL UP!

perhaps one of the best tool

Right, I’ve made a proper xrnx file for my revised version (v1.03) of the Akaizer wrapper tool. It is available for download from the official Akaizer site. Any further fixes or added features will be made available from there in future.

http://the-akaizer-project.blogspot.com/

Seems to have been a pretty common problem in the past, started happening with my version of Akaizer, tried using the updated version from the blogspot and it persists.

Complete reinstall of latest Renoise + Akaizer too.

AppData\Roaming\Renoise\V3.1.1\Scripts\Tools\com.ben.Akaizer.xrnx’ failed to execute in one of its menu entry functions.

Please contact the author (Ben) for assistance…

std::logic_error: ‘trying to load sample data from a non existing file: AppData\Local\Temp\Renoise-0-3292\Renoise_TmpFile-0-13-125%_1000_0_C.wav’’
stack traceback:
[C]: in function ‘load_from’
main.lua:123: in function ‘process_sample’
main.lua:320: in function ‘show_dialog’
main.lua:43: in function main.lua:42

Does this also work in 2.8.2 ?

there is a previous AKAIZER tool by another author (sorry i forget the name!) that works in 2.8

search and ye shall find ?

Seems to have been a pretty common problem in the past, started happening with my version of Akaizer, tried using the updated version from the blogspot and it persists.

Complete reinstall of latest Renoise + Akaizer too.

AppData\Roaming\Renoise\V3.1.1\Scripts\Tools\com.ben.Akaizer.xrnx’ failed to execute in one of its menu entry functions.

Please contact the author (Ben) for assistance…

std::logic_error: ‘trying to load sample data from a non existing file: AppData\Local\Temp\Renoise-0-3292\Renoise_TmpFile-0-13-125%_1000_0_C.wav’’
stack traceback:
[C]: in function ‘load_from’
main.lua:123: in function ‘process_sample’
main.lua:320: in function ‘show_dialog’
main.lua:43: in function main.lua:42

I need to be able to replicate this error in order to work out what is wrong, otherwise I can’t fix it. Please can you PM me a link (e.g. sendpace) to download the actual sound that you was trying to process, and also let me know the exact settings/values you used. Thanks.

Hello!

I’m kinda new to Renoise and this “How to use: Sample Editor -> Process -> Akaizer” didn’t really help me much. I have akaizer listed in my tool browser now, but I coudn’t find out how I can use it. Can anyone explain me where I can find it? I have Renoise 3.1.1

Thanks!

The "How to use: Sample Editor -> Process -> Akaizer” is literally the answer to your question… So I am not sure what you are asking for specifically… are you saying that it is not shown in the process menu in the sample editor? If not, then maybe the installation did not work correctly.

Thanks for the answer.

I am saying I can’t find the Process menu anywhere.

Previously I didn’t even know I was supposed to be looking for a menu, heh.

I am not sure either if I am looking it at the right place. Is the “Sampler” view same as “Sample Editor”?

Cheers!

Right click in the sampler and you should find Process -> Akaizer

Excuse me, when i try to download it it says “access denied”

link update if it’s relevant today? and how does it compare to native timestretch (brought in 3.2)?
Thanks

What “Sample Editor” refers to should be covered in the manual. It is the waveform view of the sampler, basically. There, you just right click to get the context menu, and in this context menu there should be a “Process” submenu.

Thanks guys! Found it finally. Too bad all I get now is the error message “Process did not complete successfully…”.

Also, there is nothing about what Sample editor refers to in user manual. That’s why I got so confused in the first place. :smiley:

Yeah, the Akaizer tool doesn’t seem to work anymore, sadly.

Every attempt to use it gives me this pop-up, as described by others here already:

00%20PM

The five sections of the Sampler are briefly detailed in its introduction section. Check the links found there if you need full details on a section you’re interested in.

“The Waveform editor displays the samples so you can edit them with the provided tools and see the results graphically. It’s also where new samples are recorded.”

Hi Ben,
Trying to get Akaizer to work get I’m just getting the message
‘process did not complete successfully’
It seems others are having this problem too…
Any tips much appreciated
Thanks
Paul