New Tool: Recycle (Rex Files) 4 Renoise

First release, new name, I still suck at coding, but it works. Maybe. Sometimes. :)

I’m very proud to announce the first public release of REX4Renoise!

This is version 0.1a. It’s not done yet. But it works. Kinda. For me, at least. This is still Mac only, it expects the REX Shared Library to be installed under “/Library/Application Support”, and it relies on SoX for now, as I couldn’t figure out how to import PCM files without headers in Renoise so far (SoX is bundled, though). And there are even more caveats and known issues: It’s mono only for now. It does work with stereo loops, but it will only actually import the left channel. It doesn’t do anything with the timing data, and it doesn’t match the tempo of your song - yet. All it does for now is to take any given REX loop, convert the slices to individual samples, create an instrument, and populate that with the slices. You have to go to the instrument editor once you’ve imported the loop and hit “Generate Drum Kit” to map the slices to individual notes (starting at C-4).

The actual usage is fairly straight forward: in the instrument list, right click on any slot, and select “Import REX loop…” (if there already is an instrument at the given slot, it will be replaced, so be careful). A file browser opens, you select a loop, and that’s pretty much it. Matching the tempo of the current song is planned, as is Windows support (sorry Linux folks, I know your pain - blame Propellerhead Software). Some way to extract and use the timing data would be nice as well, but I haven’t quite figured out how to do that yet.

And, as always, use this at your own risk! Contrary to most Renoise tools, this thing comes with a couple of native applications, one of which was written by yours truly - and I had no idea what I was doing most of the time. It didn’t blow up my rig, and I’m quite sure it won’t blow up yours, either, but I honestly don’t know, so please don’t sue me if anything bad happens. ;)

PS: Could a mod please rename this thread to reflect the new name and status of the project?

EDIT: Link updated - should work now.

Amazing stuff
Hope to try it soon (Win) and good look with the timing tempo info


cool stuff, hopefully you’ll find time for a windows version :) .

when i’m trying to install the script i get this error message:

Failed to copy the script into the destination folder (zip error: ‘Failed to open the destination file for writing:
‘/Users/kim/Library/Preferences/Renoise/V2.6.0/Scripts/Tools/de.versus.REX4Renoise.xrnx/bin/’’). Script installation failed.

same problem here

Yeah, something went wrong packing it. I guess Renoise doesn’t like files compressed using the default OSX archiver. Used Rucksack now - tested and working:

Sorry, not yet had the possibility to do proper testing (…on mac…) - but will do… Hoping to have time within the next few days…

testing, but only raw data pink noise loaded into renoise
(i have Directwave, and PhatmatikPro installed)

file list only work when i select “.
then “couldn’t convert loop”

as i say before Directwave can import rx2 or rex files so not the rex shared lyb the problem i think+
or if yes, how can i install that (won’t install any warez software)

Wait a second…

Didn’t you say you were Windows only? And isn’t Directwave a Windows VSTi? The tool is still Mac only, sorry. If you were in fact trying this on a Mac, could you please post the loop in question?

Still mac only! I understand now.

But please Do NOT make Platform Specific Tool for a Multiplatform Software!!!

New version:

REX4Renoise 0.1a2

  • Support for stereo loops.
  • Automatically set the correct permissions for r4r and sox.
  • Won’t install on unsupported platforms anymore.
  • A few bugfixes.
  • Several cosmetic changes.

Download it here:

I’ll try to implement tempo matching and automatically generating a split instrument next. After that, I’ll give the Windows port a spin.

Yeah, well, there’s no way around it I’m afraid. Like I already wrote, I can try to port my converter to Windows (or hand someone else the sourcecode if anyone steps up to help me out there), but a Linux version is simply not in the cards - that ball is in Propellerhead’s court, nothing I can do about it. On the other hand, Renoise itself might be multiplatform, but that doesn’t mean all of it’s functions are available on all platforms. Audio Units are supported and Mac specific, LADSPA is supported and Linux specific, and ReWire is supported and not available on Linux. Luckily, taktik implemented a mechanism to prevent the installation of Renoise tools on unsupported platforms - I use that from now on to not cause any further confusion.


MPlayer can use Windows codecs (DLLs) on any operating system as long as the architecture matches. The REX library seems to work very similar to codecs. It pretty much is a codec. It might be possible to hack something together using a similar approach

hope you can convert it see us windows people can try it too:)

one thing might be a idea to attach the tool to the first post.just a thought :drummer:

Also maybe get a moderator to add MAC ONLY to the title of the thread ;)

He’s doing this for fun, so I say he can do whatever he wants.

Ideally, someone can help him port the windows version. Beggars can’t be choosers.

Good times.

I had the opportunity to spend a night with my dad’s Windows PC. Porting r4r over was quite easy using MinGW and dlfcn-win32, but it doesn’t work for some weird reason. Communication with the library works, and the library is able to tell valid and invalid REX files apart, but it returns an unknown error. I’ll clean up the code and post it - maybe someone else can give it a spin.

EDIT: Here it is. It’ll probably make anyone even remotely knowledgable want to throw up and punch me in the face, but I’m proud of it. It sort of works, even though I had no idea what I was doing (and the dozens of compiler warnings prove it)… ;)

Like I wrote, this compiles and executes on Windows, but it doesn’t really work. You’ll need dlfcn-win32, a small wrapper to use UNIX style dlopen and dlsym on Windows. dlfcn-win32 is not the reason for the DLL error, by the way. I believe the two NULLs in _REXCreate are the problem. _REXCreate takes five arguments, but I don’t know what the last two arguments are supposed to be, so I simply used something (complete nonsense I assume) to make the compiler and the library shut up. :)

i tested your tool with various rex-files on osx 10.6.5. every attempt to open a file resulted in this error message:

Couldn’t convert loop. The file you tried to import might be corrupt,
or the REX Shared Library might be missing.

(The rex shared library is located in Library/Application Support )

edit: maybe installing sox would help :unsure:

Odd. You tested with the 0.1a2 release I assume? In the first release, r4r was not set up with the correct permissions, so the tool would always spit out that error message. Also, is the library in “/Library/Application Support” or “~/Library/Application Support”? Only the first path would work. Either way, the way I load the library seems wonky, and I’ll need to add a couple more sanity checks…

And no, you don’t need to install SoX manually. It’s included.

yes, i tested version 0.2a2 and the rex library is located in /Application Support.

REX4Renoise 0.1a3


  • Added some checks to see if the REX Shared Library was correctly installed.
  • More verbose debug output (only available from the command line).
  • r4r built with different compiler flags - should be faster and more compatible.
  • The r4r binary supports PPC now (in theory - but it currently requires OSX 10.6, and 10.6 isn’t PPC compatible).

Download it here:

And yes, it’s still Mac only. ;)

@capitán kazoo:

I had to make a couple of assumptions about the exact path and filename of the library. I just noticed that I have a boatload of REX Shared Libraries on my system, in a few different directories - and some of them are simply aliases for legacy PowerPC versions. Maybe the hardcoded path I’ve initially used is outdated. In 0.1a3, I now look in what I believe is the current default path ("/Library/Application Support/Propellerhead Software/Rex/").

If it still doesn’t work for you with 0.1a3, please open a terminal, enter “cd ~/Library/Preferences/Renoise/V2.6.0/Scripts/Tools/de.versus.REX4Renoise.xrnx/bin/osx”, followed by “./r4r r4r”, and post the output.