No Audio In Master

This might be a non-bug, but here goes:

I have the delta 1010, and because of some hardware issues I’ve been forced to use the second set of channels for the output. Now to use this with ASIO You have to go to each individual channel and nominate ‘option 1’ appearing as a little 1 instead of an M in the top left of each channel. It would be nice to change this globally for ASIO, but that isn’t my concern right now -

When using all the channels on option 1 (or any other option other than ‘M’) I cannot get any audio going through the master channel, even though I can hear it fine. So nothing appears in the master scopes. When I try to put a vst or native effect on the master channel it does not affect the sound at all.

Is this because the master still thinks it’s on ‘M’?

I’ve noticed this before, when I had accidentally changed an output away from the first pair, when I solo’ed it to work on some nuances it did not display in the master scopes or register on the spectrum analyser. Think I mentioned it then but never got a respone. I have since set Renoise to work in stereo only otherwise it makes the output from my wave editor distorted and unusuable, so not something I have given thought to since…

Thats more a missing feature:
When working with multiple physical outputs, every output is routed seperately from the master to the soundcard. As you can not apply the same set of effects to two or more seperate channels at once, we would need to have a “mastertrack” for each physical output. Got it?

As a workaround, you could now use sendtracks: route all tracks into one sendtrack, apply the effect there, and then route the sendtrack to the physical output 1… Well, or give us some more details why the master out of your soundcard does not work…

That’s not applicable to Renoise as an app, that’s something I’m waiting to hear back from tek support from M-Audio about. I’m using my second output set for now as a workaround, and hopefully the situation will not be permenant. It’s a pain re-setting every channel to ‘1’, and nearly as tiresome to set up a ‘master send’, with all tracks pointing there.

I share Bantai’s concern. Wouldn’t it be easier to set the output on the master channel as a ‘default’? Then if people wanted individual channels to other outputs then they could miss out on the master effects? I spose that would be hard to program also.


Because if it wouldnt, you could not control the overal volume via the master volume slider.

Yes, that would be possible:
We could add one more entry for the routing choosers: “Master”. To the “Master” routed tracks would then send its signal to the master track (including its DSP effects), and you then could choose a routing (excluding “Master”) for the master track itself to route its signal to a physical audio channel pair. This way you could route all signals with a single click to a different physical audio channel…

That would be a great solution! ;) :D

For me to be able to use a wave editor with asio at the same time as having renoise open I have had to set renoise to use stereo outputs only. Would it be possible to have renoise use a user-definable number of the outputs on your card so that a pair could always be left for another program?

Thought if you were looking at how renoise addresses it’s outputs you may as well go the whole hog ;)