[nobug] Semi-permanent muting of Line-In Devices


happens with Renoise 3.01 32bit and also 3.1 b332bit/64bit:


I use the maudio fire 1814 + korg m3 via firewire cascaded on OSX 10.9.4. I use a aggregate device where clock is the m3 (is required).


I control the M3 thru a midi instr. and thru line-in device in midi return-mode etc. See template song:

Attachment 6166 not found.

What happens:

Everything works fine until I press stop button one time on top. The line-in device is now muted, no matter what I do. Even key presses directly on M3 don’t trigger a input level. Reinitialize audio device doesn’t help. Also swapping input channels doesn’t help.The only fix is to restart renoise. EDIT: Playing another instrument or press play also fixes it. Everything works again fine. No restart of devices or whatever.

What is expected:

The line-in shouldn’t be muted permanently.


If this mechanism was meant for muting accidentally audio bursts like feedback, I would suggest to enable it after the second stop click instead the first stop click.



  • Press play.

  • Put in a VSTi on slot 2, select it, play it once , and again select instr. no 1 (m3).

EDIT 2 offtopic:

What I really like in 3.1, that I now can actually directly use M3 as input device and maudio as output device, without an aggregate device. This doesn’t work in 3.0 without crackles. Nice :slight_smile:

This is done on purpose when applying “panic” in Renoise. For example by hitting the stop button while the song is already stopped.

If there’s some horrible noise or feedback coming through the line-In devices, then “panic” should kill that noise. That’s what “panic” is for: shut off everything.

Now if Line-In devices are stopped by panic, something must re-enable them too. We though starting the song would make sense here.

Oh ok, understand, maybe make it double-click stop ( as far as I know standard for “midi panic” in most daws ) ?

Anyway I can live with it :slight_smile: