OSX Catalina: crash opening an old XRNS song

Hello there

While browsing through some ancient song files that hadn’t been opened in years, I found that Renoise would crash immediately upon opening many of the xrns files. It doesnt happen on all songs, but the ones that produce the crash do so every time I attempt to open them. This happens while opening from Finder or the Renoise file browser. Using the Renoise file browser I can expand the xrns that cause the crash and browse their samples successfully but cannot open them without a crash. There’s really no steps to describe other than simply opening the xrns file from finder or the Renoise browser.

What do I need to provide to help diagnose this problem? Any assistance would be appreciated.

I’m using Renoise 3.2.1 a 2018 Mac Mini running OSX 10.14.6

Copy over the crash log from the Renoise log file, found in /~/Library/Logs/RenoiseXX/Renoise.log. Most likely it is caused by a vst.

Thank you ffx, I had a feeling a vst was responsible. Renoise.log (1.6 MB)

I am not an expert, only @taktik will know. But I cannot find a reference to a plugin in your crashreport.

Does it crash in Renoise 3.11, too? If nothing helps, you could remove every plugin used in the song from the vst dir one by one and reload the song each time, until it does not crash anymore (showing error messages only). Then you would know which plugin is the cause for the crash.

You can see which plugins are used in the song by opening the song.xml (inside the .xrns which actually is a zip file) in a text editor and then searching for “pluginidentifer”.

Also if you have sandboxing enabled, try to disable it (and restart Renoise once). Then the crashlog might provide more useful info. Are you using any 32bit plugins?

@centipus could you share the song file with us too, so we could have a closer look at this. If you don’t want to share the song with everyone, drop me a private message on this forum.

Thank you for the help taktik and ffx

3.1.1 will successfully open the songs that produce the immediate crash in 3.2.1. I am running all 64 bit as far as I know.

This song always crashes 3.2.1

Just curious @centipus Does loading any of these song files crash Renoise 3.2.1 on your system?
FKZM23_mod_1.xrns (8.4 KB)
FKZM23_mod_2.xrns (7.8 KB)
FKZM23_mod_3.xrns (5.9 KB)
FKZM23_mod_4.xrns (5.2 KB)

@4tey i will check this evening when i get back to the house. what did you change in those variations? thanks for the help by the way!

All they are is cut down versions of your FKZM23 file. The first file FKZM23_mod_1 is just essentially the same as your original but with the samples and pattern data removed. In a way banking on that still crashing(?) due to the presence of Synth1 vst.
File FKZM23_mod_2 is just Synth1 vst and no AU effect. So that might still crash.
File FKZM23_mod_3 is just the AU effect but no Synth1. That might load okay(??)
File FKZM23_mod_4 is no Synth1 and no AU effect. That might load okay(??)
I was just wondering if it was Synth1 vst that might be causing an issue with Renoise 3.2.1.
I can tell you that your original file does load under Renoise Linux…albeit without the Synth1 vst or the AU effect aaltoverb :slight_smile:

Synth1 64bit has a broken filter on macos. Here is a version with removed 64bit part, so it loads like a 32bit plugin:
Synth1.vst.zip.xrns (349.1 KB) (remove the .xrns from filename)

interesting. I do not have synth1 or the AU reverb in that track installed on this computer

Ah, so if you load up your original FKZM23.xrns file in Renoise 3.1.1, it loads fine with a requester saying it can’t find Synth1 and Aaltoverb plugins. But Renoise 3.2.1 crashes when it can’t find missing vst/au plugins(?)

yes, this is exactly what happens

All four of these files open successfully with 3.2.1 here

That’s interesting. If you open any of those files in Renoise 3.2.1, do you get the dialog telling you what the missing plugins are? i.e.
missing
You see if you do, then unfortunately it is more tricky. As I can’t reproduce the crash with your original FKZM23.xrns under Linux I can’t try and work out what is causing the crash.

Maybe worth mentioning that your FKZM23.xrns was written/saved under Renoise 2.8(?) Finally could you just try to see if these load in your Renoise 3.2.1 @centipus:
FKZM23_nosamp.xrns (47.3 KB)
FKZM23_nosynth.xrns (45.0 KB)

Weird, just FYI, your song (first post above) loads fine here in Renoise 3.21 using macOS 10.13.4 High Sierra (not finding Aaltoverb).

1 Like

Just to clarify you have Synth1 installed @ffx?

Yes, the version I posted above (with removed 64bit part from universal executable).

But this might not be related, if I removed synth1.vst from vstplugins dir, it still loads.

Ok :slight_smile:

yes I get the missing plug dialog in 3.2.1 with your modified files 1-4

this file, FKZM23.xrns and all the ones that produce the crash are from 2012 or so, perhaps i was into some specific plugs at the time that i dont have anymore.

Both of those, nosamp and nosynth, mostly produce a crash upon loading for me. occasionally they will open. this is crazy.

thanks everyone for your help