OSX Mojave: Microphone/line-in device input not working (silent)

I’ve been happily using Blackhole (https://github.com/ExistentialAudio/BlackHole) as an in device to pipe output from Csound into Renoise, and it seems there’s been a regression in the latest bugfix 3.2.2, in that there is silence at the Line Input device.

This is on Mojave.

I can’t see any changes in the bug fixes list posted on this forum that would point towards this. The only thing that happened is that Renoise asked to install the latest version of Rewire, which I’m not using here

1 Like

Probably the microphone and line-in devices got disabled by Apple’s new “security” features.


on how to resolve this please.

1 Like

Hi @taktik, this is already configured as proposed in the docs, and i’ve tried checking box off and on again, but still no success, and after few times doing this - it actually worked. Wtf apple…

Worked for me too, thanks.

If I had to hazard a guess, I’d say that macOs is your least favourite platform :grin: