OSX: Problem with Renoise as rewire slave to Logic 9


I’m running Renoise 2.7.2 , Logic 9.1.8 , and I just updated my OS to 10.9 “mavericks”. I was running OS 10.6 before and Logic was working just fine as renoise’s rewire master, but now when I open Renoise (after Logic) it doesn’t ask me whether I want to run it as slave or not.

Both Logic and renoise are set to 32bit. I tried reinstalling Rewire but to no avail. Logic was giving me an error message before saying that I should restart and try again to run Renoise as slave, but now there’s no message or anything.

What should I do?


There have been a number of documented issues with OSX Mavericks and various audio software titles:

Have you tried installing running / re-installing both Logic and Renoise as 64-bit applications? From what I understand OSX Mavericks is a 64-bit only OS but I’m not sure if this matters… Aside from my newish Win7 desktop I’m still using a G4 powerbook running 10.4.11 so not really up to date on these things :lol:/>

I didn’t know that OSX mavericks was 64-bit only!


Make sure Logic is starting in 32bit mode, when Renoise is 32bit too. Right click Logic.app, then look out for a “Open in 32-bit mode” checkbox.

If this does not help, try to reinstall the Renoise Rewire engine. Probably it got broken after the OS update.
To do so, open '/Library/Application Support/Propellerhead Software/ReWire in Finder, then delete the Renoise link in there. Start Renoise. It should then ask to reinstall ReWire.

If this does not help you may try to delete the ReWire.bundle in that folder too, but keep a copy of it in case this has not changed anything.