Pattern Editor Not Scrolling Up And Down

how about if there was an option so that the pattern editor didnt scrolled… so it would be fixed (if the pattern’s lenght fitted the screen).

this might sound not interesting at all for someone already used to renoise but im used to psycle and in psycle if the 64 ticks (or whatever ticks) fit ithe screen then the pattern doesnt scroll…

what’s the advantage of this ? its much easier to locate notes and events in a pattern since everything is allways in the same place and not going up and down everytime you move the cursor.

scrolling sucks in any kind of editing!

1 Like

that allready exist

see :

it’s the button with the arrow pointing down

I don’t think he means pattern following: he would like to move the cursor on a fixed (and stopped) pattern, while not in play mode.

1 Like

ah indeed, my mistake .

I too have a rather big screen (24" TFT widescreen from dell) but I mostly use 128_line patterns . So I never needed this function.

It would be a nice option indeed , have it nested somewhere in the Patern_Config where you can enable/disable the framework and change position_numbering from HEX top DEC

Oh well , I don’t know if it’s possible :unsure:

This crossed my mind once too. It could function like a normal text editor… when the pattern is too large to fit on the screen it would scroll only when you move to the edge.

It-Alien is right, im not refering to pattern follow…

another advantage of this is that like that you get to see the full pattern in one glance and dont have to scroll to see all the pattern. (in the case that it fits the screen)

in the past when ive used FT2 it behaved the same way as renoise does now, only when i ve moved to psycle i could see how much better was not having a scrolling pattern.

1 Like


1 Like