pattern editor step lenth midi controller issues

can’t seem to get my evolution mk-249c to enter data at the right step length- it seems to enter information at double the step length. resulting in an inability to enter data one line at a time (will only do two) yet when using the computer keyboard its fine. resolve anyone?

It looks like the note-offs aren’t being sent or received, is the note-off midi signal checkbox checked in the Midi preferences?

The edit step should listen to both Midi and computer keyboard.

I believe there is only one exception:If your instrument is completely empty (no sample / midi or VST reference available), so make sure your Renoise instrument does actually contain something.