Plugins not displaying properly

Plugins are all scaled way small, and this does seem to be the inverse of the UI scale setting. Sadly, setting my global UI scaling to 100% is not an option. I’ll explain:

So there was a solution accepted here in this thread: Plugins not displaying properly

Sadly this solution will not work for me since using 100% UI scaling on my built-in HiDPI display makes everything else far too tiny to use. I only have this one display. :grimacing:

Is there another possible solution, please? Super unfortunately, this is preventing me from using Renoise as my primary DAW. I can pretty much only use it for sample slicing and patterning right now. I would love for this to work again. At least now the problem is more consistently happening. Most especially with Vital.audio plugin and with Roland’s plugins.

Thank you!!

2 Likes

Go where you load the plugins and on the right click the little button that has 3 lines,then you can uncheck auto-scale and reload the plugin.

3.2_plugineffects-compatibilityoptions

1 Like

Oh man, I got so excited when that worked for the first time the plugin loaded. Sadly, after that it looks like this:
image

Does vital have its own scale settings somewhere?Check if you can find any scale settings in the plugin it self and change it

Indeed, it does, but these are set to 100%

What happens when you change it?Restart Renoise load vital again and check the compatibility option see if the auto scale is unchecked

Cool, reloading it right now. When I changed the setting originally it loaded “properly”. I put that in quotes because I was checking to see if a single plugin (Vital) was scaleable, which it’s supposed be… interestingly, the plugin loaded on first load as the proper size and the window itself allowed scaling. Upon re-loading the plugin in the same Renoise instance, the window looks as above and is no longer scalable.

I’ll reply in a min with what happens on a reload of Renoise. Thank you much for your help!!

1 Like

image
image
image

Right, yeah, on reloading Renoise, sadly the same results. I checked the plugin settings and it didn’t revert. I kinda hoped it had so that the explanation would be easier.

Thank you again!

Are you on Mac?If so there is a thread about something with the RGB profile or something like that ,that you need to change but I am not on Mac so search the forum for Mac problems.What is your PC monitor?My monitor has a scale option on its own maybe yours has that option too so change it if that is the case.Make sure you have the latest vital version or if you do try downloading an older version you never know it could work.

I wish I was on a mac sometimes haha. Apparently the audio processing is way better natively. Alas. I’m not a mac guy.

I am on a PC. I have a built-in display on my laptop. The resolution is set to native, which is a ridiculous number of pixels …
image
Resolution: 3840 x 2160
Scaling: 250%

If I change the scaling to 100% then I need bifocals to see the screen hahaheh
image

If I set the resolution lower then I get blurs on lines and things, cause anti-aliasing. I could disable anti-aliasing but that means jagged lines everywhere…

These are all totally reasonable things to suggest for sure, and if I do all these things then it works. I suppose I could be really really disciplined with Renoise and set these things every time I want to use it and then only use Renoise, and then set them back when I’m done… dang. I’m not that disciplined though. I blame my father :wink: haha I’ll could write a .bat script to set these things and then open Renoise perhaps?

I might try an earlier version of Renoise. I feel like this is a kind of recent problem. :confused:

I don’t think it’s Renoise problem.Vital is buggy on high resolutions as helm vst was from the same developer.Try scaling of 150 I have my screen at 125 and have no problems.Also did you make any changes in windows regarding font size ?

No, my font size is default. I’ll check the 150 or 125 scaling resolutions and see if its livable/readable…

FWIW in the other 3 DAWs I have this problem doesn’t happen, but that may just come down to a difference in addressing or which methods are used of the Windows API.

Oh man, at 150% it’s really hard to read. I still can, but it’s not really usable… :frowning:
Here’s a Roland 909 at 150% scale, for counter balancing the testing:
image

And then here at 250% scale
image

You’re absolutely right about scaling issues in Vital. That is a thing, for sure.

It’s a slightly different, but very similar issue with Roland plugins. They sometimes appear correctly, and sometimes are like Vital, and sometimes the window is actually the same size as the display, just way too small (as in the screenshot.)

I suppose it’s possible that it’s all these plugins themselves, but seems more to be some interaction between Renoise and these plugins, like it’s really both of them not playing well. FWIW they do work fine in ableton, bitwig, and maschine.

Damn I really want this to be a setting I can configure. I feel like I’m still missing something maybe… ?hrmmmmm

1 Like

Consider working on an external monitor that has way smaller resolution if nothing works.

1 Like

I think for now this is what I’ll have to do.
I will see about borrowing a monitor or getting a portable secondary display (as I’m away from home right now)

Thank you again!!

1 Like

I had the issue in the thread you linked in OP.

Following the advice there, I changed Windows scaling down to 100% and closed the plug in and renoise. I then restarted renoise and loaded the plugin. This worked but then was smaller than I would like. I then set scaling back up and reloaded and the plugin seems to work at the correct scaling. It just means restarting a couple of times

Strong advice! Thank you @Rex! I’ll have a try at this tonight. :crossed_fingers::crossed_fingers:

Same issue with vital, already wrote a post…

Not solved for me